Lancer Register Forum banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
I have noticed that my EVO has begun to idle stangely,. Its sometimes dips quite low like to about 500rmp but not when completely stationery and idle, rather when you dip teh clutch and begin to move forward.

Anyone had this problem... what should teh EVO idle at in any case ?
 
G

·
Discussion Starter · #2 ·
Jackal,
First thing to check for is any air leaks on your intake system. do you have a BOV fitted, if so then check that its not leaking air past the valve on idle and causing extra air to get into the intake system that the ECU doesn't know about.
Another possible option is if you've had your battery disconnected recently and the ECU is busy re-learning its fuelling settings and the best way to combat this is to let the car idle for a while until it starts to run normally again.

Hope this helps

Andy
 
G

·
Discussion Starter · #4 ·
The fuel thing sounds reasonable as filled with Optimax the other night and my idle went strange untill I opened the car up and cleared it,but was a matter of a couple of traffic light stops .dropped to around 600 then back to 800.
with a stall in between .then absolutely perfect as before.
Now I know not to worry.
 
G

·
Discussion Starter · #5 ·
Yup, I have the same problem now and again.....

remember at the services, when I sold you that CAT ?

....... They just do their own thing sometimes don't they !

Jonathan
 
G

·
Discussion Starter · #6 ·
Yeah remember you saying about it now .I experience it only when changing fuels or putting octane boost.
happens for about 20 seconds.
Going to reset the ecu with battery disconnection which should speed up the Ecu learning.
Noticed your web site construction for R C developments ,nice touch.
 
G

·
Discussion Starter · #7 ·
I had the same sort of thing after fitting the HKS induction kit.
Being Stupid. I had forgot to reattach the connection to the airflow meter thus getting strange idle.!!!
 
1 - 7 of 7 Posts
Top