Lancer Register Forum banner

1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
have not used the car for two weeks and just got the HKS turbo timer fitted and now the idling of the car is very uneven like it is going to stall.

I think I might have a leak in the wastegate but does this bring along the idling problem or it is the turbo timer?

thanks


Lawrence
 
G

·
Discussion Starter · #2 ·
Interesting, I was just reading about the way the ECU operates, taking time for example to figure out what's happened and needing time to adjust, sometimes resulting in rough idle. http://www.tmo.com/faq/diagport/970915.htm
 
G

·
Discussion Starter · #3 ·
Sounds like the battery was disconnected and like Aaron suggests, the ECU is re learning. I've had the same thing happen when I've disconnected my battery to reset the ECU . There is a proper way to run the engine once the battery has been disconnected but I'm not 100% sure. It's something like let the engine idle for 20 mins then drive normally (not thrashing
 
G

·
Discussion Starter · #4 ·
Batman why not have it checked out on the mut at your local dealer,it might only need the isc motor resetting.
 
G

·
Discussion Starter · #5 ·
Anna - how do you reset the ISC?

Batman - just how unstable is the idling? Is it all the time or just when hot or when cold?
 
G

·
Discussion Starter · #6 ·
thanks for all the advice.

The idling goes to the range like 1.2 and drop to 0.7 to almost stalling when the car is stationary at the lights.

By the way, what is ISC setting?


Lawrence
 
G

·
Discussion Starter · #8 ·
i had this same problem weeks back (when i got the car from japan) and after the ECU reset ie. ensure the car is warmed up first, remove the -ve battery terminal for approx. 15mins, ensure all accessories/air-cond unit switched off to release unnecessary engine load, then reconnect the -ve terminal... start the car and let idle for 15mins without touching any foot pedals, then off the engine to complete the job... viola!! you've just resetted the ECU... and no more idling problem at light thereafter... i'm a happy man now!! just couldn't be easier...

but if the above still doesn't work/help, consult your local workshop for MUTII diagnostic!! cool stuff huh...
 
1 - 8 of 8 Posts
Top