Lancer Register Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5,600 Posts
Discussion Starter · #1 ·
Just looking for some advice, not really sure what went on yesterday with my turbo.

Ran all morning on track fine, about 60 miles of abuse with no problems / smoke / oil burning.

Half way around session before lunch, turbo goes. No smoke, no noise just no boost.

Pull into pits cant see any obvious faults (pipes off etc)

Remove inlet pipe onto turbo, and the compressor wheel is siezed. I give it a firm push with my two fingers and it free'd up. No abnormal play in the turbo shaft.

Go out, got full boost and its running prefect again. Did another 50 odd miles of track abuse and it's fine again.

Not sure weather to change the turbo, or leave? :confused:

John. :wallbang: :wallbang: :wallbang:
 

·
Anthony
Joined
·
3,743 Posts
That's bizarre...

I'm a big believer in 'if it aint broke, don't fix it', but that is a bit scary mate. Unless you got a chunk of rubber go through and you dislodged it and it's now jammed in your Intercooler (have seen that few times)..., I have no idea what that could be... might pay to at least pull the intake pipe off and check, then maybe the turbo..
 

·
Registered
Joined
·
1,081 Posts
Just looking for some advice, not really sure what went on yesterday with my turbo.

Ran all morning on track fine, about 60 miles of abuse with no problems / smoke / oil burning.

Half way around session before lunch, turbo goes. No smoke, no noise just no boost.

Pull into pits cant see any obvious faults (pipes off etc)

Remove inlet pipe onto turbo, and the compressor wheel is siezed. I give it a firm push with my two fingers and it free'd up. No abnormal play in the turbo shaft.

Go out, got full boost and its running prefect again. Did another 50 odd miles of track abuse and it's fine again.

Not sure weather to change the turbo, or leave? :confused:

John. :wallbang: :wallbang: :wallbang:
I've got a my old 8 turbo if you've got problems m8
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top