Lancer Register Forum banner

1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
Any of you guys that were hurtling round Silverstone at Trax on sunday... what Brake setup were you running and did you get any problems at all over the laps you did...

Be interesting to hear about your experiences to help me decide on the way forward with the brake setup..

Cheers

Jevo
 
G

·
Discussion Starter · #2 ·
Jevo,
I was running completely standard pads and discs and have had no problems before or since TRAX. I wasn't particularly hard on them but then again, perhaps I'm just the lucky one.....

Andy
 
G

·
Discussion Starter · #3 ·
or maybe just a girly one http://www.lancerregister.com/graphics/laugh1.gif border|EQU| 0 align|EQU| absmiddle >[img]http://www.lancerregister.com/graphics/laugh1.gif border|EQU| 0 align|EQU| absmiddle >[img]http://www.lancerregister.com/graphics/laugh1.gif border|EQU| 0 align|EQU| absmiddle >[img]http://www.lancerregister.com/graphics/laugh1.gif border|EQU| 0 align|EQU| absmiddle >

lee.

ps. are you and su up for meet in october (see other postings??)
 
G

·
Discussion Starter · #4 ·
I have standard original discs and calipers with Mintex 1144s and castrol response brake fluid and have absolutely no problems with my brakes and I use them very very hard on many track days and daily on the road. At Silverstone I managed to stay with E4 RS running AP brakes, Proflex, Motec and slicks for about 3 laps before my SO2s totally overheated! My car is silver E6 GSR, Exhaust, Filter, LEDA, 26K miles. Discs bedded in for 4K miles from new.
 
1 - 5 of 5 Posts
Top