Lancer Register Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
290 Posts
Discussion Starter · #1 ·
help if i had sump wash would my tappets start to tick due to lack of off oil help evo 1 . if not any idears lover evo1
 

·
Registered
Joined
·
138 Posts
dont know what sump wash is but if the oil is thin i exspect u would. they might just need cleaning out and refitting , mine used to do it on start up common problem ive been told but clean mine and had no probs since; could allso be type of oil used , and has it been changed recently,
 

·
Registered
Joined
·
290 Posts
Discussion Starter · #4 ·
thanks but oil changed last month. only started ticking after giving it a long drive any body got a price please either new ones or cleaning them out thanks for any help mat :)
 

·
Registered
Joined
·
1,745 Posts
I'm not sure if the uprated tappets from Evo 400 are available for the Evo I but I had a set fitted to my VI by [email protected] and have ahd no problems since. The uprated ones havea bigger hole which does not get clogged up and therefore does not trap air which causing the ticking noise.

If you can be bothered to clean them regularly then this will solve the problem too but I've heard that after a few months the ticking is back and the tappets need to be cleaned again. That's why I went for teh uprated set. PM [email protected] and see what he'll supply and fit them for, I think his website specifically quotes this job.
 

·
Registered
Joined
·
569 Posts
mines the same it does it when cold and comes and goes when hot NED FLANDERS told me that they can be picked up for £200 for the set and apparently are a piece of **** to fit

when you did a sump wash/engine flush did you replace the oil filter.

FAO hobbers is it possible to drill the exsisting holes bigger?

i was told of an oil that wil reduce the noise can't remember what it's called if any one knows can you post it up cheers.
 

·
Registered
Joined
·
10,666 Posts
er they are stock replacments . say nothing about being uprated units . oe units are made in europe and thats where EVO400 has are units made .

fire them a email first !

dave
 

·
Premium Member
Joined
·
16,914 Posts
Er......

"16 Topline "Revised" 4G63 Turbo Lifters. Elimanates annoying lifter tick from years of wear. These lifters will work in any 4G63 Head 1G or 2G"

Worth a shot at that money imo ..drop Craig or Nate an email, most of the lifters for sale in the US are uprated/revised ones with bigger holes ( they have a lot more 4g63 motors over there than here) but check them out.

Ian
 

·
Premium Member
Joined
·
16,914 Posts
Fair comment another typical ebay brand name :) , can you tell us the name of the company that makes the ones you supply out of interest ?

Ian
 

·
Registered
Joined
·
10,666 Posts
i will tell you they are made in spain . we have tryed alot of the US brands , but theses do come from the oe factory thats why we use them . cost i am afraid is the last thing on my mind when installing engine internals .

dave
 

·
Registered
Joined
·
1,745 Posts
spook said:


FAO hobbers is it possible to drill the exsisting holes bigger?

I'm sure ANYTHING is possible but I don't think it is a simple as just drilling a bigger hole. They would have to be properly machined.

The uprated ones are the way to go IMO and if you think you can fit them fair enough. For me the Cam cover is for looking at not for unscrewing :D

I'm not lazy I'm supporting the economy! :)
 
1 - 20 of 24 Posts
Top