Lancer Register Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
2,715 Posts
Discussion Starter · #1 ·
took my car in a while ago he put a new clutch and gearbox in fitted autronics boost gauge and controller and new pads all on a tight timescale cheers gaz absolutely top notch job car feels like new now matey :D :coolsm:
 

·
Registered
Joined
·
6,251 Posts
Yep, same from me. :coolsm: Went in with an elusive clunck/knock on the front, Gaz wouldn't let it leave 'till it was sorted. On and off the ramps trying different stuff, me asking daft questions and generally being in the way for 6 hours. :rolleyes: Also had a boost controller fitted due to the fluctuating boost but alas, it will be going in for a new turbo in approx. 1 week :cry: Still, I know I will be looked after. ;) :smthumbup :D

Pete
 

·
Registered
Joined
·
2,715 Posts
Discussion Starter · #5 ·
glad you got your problem sorted pete :coolsm:





tom it has made me smile twice as much since having it done defo the number one mod to do :D :coolsm:
 

·
Registered
Joined
·
2,715 Posts
Discussion Starter · #8 ·
looks good if its the one in his garage with the cpp plate on it and its white :coolsm:
 

·
Registered
Joined
·
639 Posts
Pete Iles said:
Yep, same from me. :coolsm: Went in with an elusive clunck/knock on the front
Pete
Was it the top mount in the end Pete.

My too has just started with the same problem.......driving me nuts i can tell ya.
 

·
Registered
Joined
·
6,251 Posts
red baron said:
Was it the top mount in the end Pete.

My too has just started with the same problem.......driving me nuts i can tell ya.
I recently had top mounts done so we didn't even look there. It ended up being a drive shaft. :) Thank God it's sorted. It really was driving me mad. :( I'll tell you what though, poly bushes sure make a difference! :coolsm:

Pete
 
1 - 14 of 14 Posts
Top