Lancer Register Forum banner
1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
my mates 6 surges under hard acceleration ,same rhythmic pulse every time every gear
this is now exagerated since turning the boost up
any ideas anyone,what symptoms does split wastegate diapragm give ?
seems to get worse as car gets hotter/used longer until it becomes quite pronounced
turning boost down masks the fault
but fault has always been there however slight
its not a faulty sensor,we have had it plugged into mut and all ok
 
G

·
Discussion Starter · #2 ·
This sounds like too much gain. Does he have a boost controller? The same thing happens to me if I run too much gain on my boost controller. Gain is the setting where you set how quickly the turbo is trying to achieve maximum boost, or in other words how steep the boost curve is. Now, when you set it too steep, you get surges as the turbo can't hold the pressure, and then tries to recover, can't hold it again, etc...
The same will happen if you have done some mechanical modifications that affect gain. The greatest factor influencing this is outside temperature, I can run about 20% more gain during winter compared to a warm day right now.
 
G

·
Discussion Starter · #3 ·
yes using blitz dsbc,but the problem has always been there very slightly
his car is similar spec to my 5 and i run 100% gain with no problems
ill try turning it down,but feel this is a fix not the cure
 
G

·
Discussion Starter · #4 ·
Mouton my good man. Check to see whether your friends Evo has the dump valve fitted correctly! I find that for serious driving, you can't beat the jubilee clips with the little Ralliart logo on them, aligned at 35degrees naturally.
 
1 - 4 of 4 Posts
Top