Lancer Register Forum banner

1 - 5 of 5 Posts

Registered
Joined
2 Posts
Discussion Starter · #1 ·
Ok car has been on long term storage for many years.
Here's my list of potentials bearing in mind I have tried jumping it off two known running battery's and also removing and testing the starter motor and cleaning black lower spade connection.
Remove turbo timer and put original loom plugs back together.
Remove steering wheel cowling and check for play in the starter switch.
Link out/etc the starter relay to test the circuit.
Check/ clean starter fuses.
Sure I have missed something ? Any feedback would be ace馃憤
 

acting daft since 1969
Joined
19,575 Posts
put a NEW battery on the car ,jumping a dead batery from a heathly running car it wont do it

also have you put some new fuel in
 

Registered
Joined
2 Posts
Discussion Starter · #3 ·
put a NEW battery on the car ,jumping a dead batery from a heathly running car it wont do it

also have you put some new fuel in
Sorry meant I removed battery from a running car disconnected battery in the boot.
Have positive and neg terminal posts in engine bay.
Yes fuel is fresh and also stabilised.
 

S.Wales R.O./Electrician
Joined
4,126 Posts
Ok car has been on long term storage for many years.
Here's my list of potentials bearing in mind I have tried jumping it off two known running battery's and also removing and testing the starter motor and cleaning black lower spade connection.
Remove turbo timer and put original loom plugs back together.
Remove steering wheel cowling and check for play in the starter switch.
Link out/etc the starter relay to test the circuit.
Check/ clean starter fuses.
Sure I have missed something ? Any feedback would be ace👍
Will the starter crank the engine in-situ when you apply 12v to the small terminal on the starter?

Do you have a 12v crank signal coming from the ignition switch when you turn the switch to crank?

Evos don't have a starter relay or fuses so what did you check there?
 

Premium Member
Joined
139 Posts
Remove your battery from the car bring it in doors and charge it on main for least 12hrs

Red fit and strategic engine with no lights or auxiliaries on for half an hour.


Then finally use the alarm and it should reset.

Clean main earthing strap.

Use some wd40 on rusty or corrosion on terminals
to clean and registered grease to avoid bad connections.

These things can happen or buy a new battery if you current battery
Is to weak and no good.
 
1 - 5 of 5 Posts
Top