Lancer Register Forum banner

1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
I have a question for everyone out there who is running high boost and high power. (over 1.5 and 350).
What spark plugs are you using ?
Now that the cold weather is on us when I start boosting to over 1.6 or 1.7 bar, I am getting missfires when using high revs (over 4000), these missfires are intermittent and only happen when it is very cold. I have improved the problem by changing my plugs to NGK heat rating 9. What are the rest of you guys running on ?

Markja
 
G

·
Discussion Starter · #3 ·
Markja

I,ve had this very tiny seems like missfire aswell and your right
it is the spark plug that makes the difference.
My dealer is sending me some new plugs at the moment so i,m waiting to see which ones
there going to send.
For now i have got round the problem by closing the gap a tiny bit on the spark plug. [no more missfire .:)]
gl
 
G

·
Discussion Starter · #4 ·
Mouton's...

Did you suffer from missfires before moving to HKS?
What heat range are you HKS plugs ?
and finally,what boost level are you running at ?


Evo7....

I would be very intersted to know what plugs your dealer supplies

Regards
Markja
 
G

·
Discussion Starter · #5 ·
Hi Marja,

The plugs you are using are way too cold for everyday driving. Your plugs are now fouled hence the misfires.
Only heavily modified Evolutions that are used exclusively for racing use 8 and 9 heat ranges. If you replace the 9 with new ones the misfire will go away temporily but eventually return if driven on the road. You might be able to get away with an 8 heat range, however Evolutions come with a 7 plug and these are normally good for up to 400 h.p. I hope this helps you.
 
1 - 5 of 5 Posts
Top