Lancer Register Forum banner

1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
The aircon in my EVO 6 has started smelling like an old dishrag.

Just for the first few seconds after I switch on, it stinks... and it's getting worse.

Gotta be water in there somewhere... anyone else have this problem? Know how to fix it?

Ta

Bloodaxe
 
G

·
Discussion Starter · #2 ·
Bloodaxe .

you been having sweaty arm pits previosly?
A mate of mine used to smoke and when he put his on you got a wiff o cigars.moisture must get in to the airducts of the conditioner.hence pumps back in whats been previously in the air.

cheers

paul
 
G

·
Discussion Starter · #3 ·
its bacteria in the condenser unit and (apparently)can be quite nasty -fopr human health, not the car - no real worry !!

An aircon specialist can disinfect the system for you - we have one in Lincolnshire but don't know where you are
 
G

·
Discussion Starter · #4 ·
Every aircon system I have had has the same smell. Especially noticeable if you put the blower on without A/C after it has condensed. Goes after about 10 seconds.

Hasn't killed me yet.
 
G

·
Discussion Starter · #5 ·
Yeah ! My 6 has smelly air when I use the cooling, then switch to non-chilled.
No outbreak of Legionaires disease to report as yet !
Do we need to send some form of anti-bacterial agent into the system ?

Mr Mime
 
G

·
Discussion Starter · #6 ·
got the same problem with my 4, i just went to H*lf*rds and got me a smelly thing to hide it!!!!
 
G

·
Discussion Starter · #7 ·
I went to Motorist Discount Centre today, they sell An aerosol for de-odorising and dis-infecting air con systems it`s about £5 a can.
will give it a whirl in mine and get back to you all
 
1 - 7 of 7 Posts
Top