Lancer Register Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
Hi,

I have UniRoyal RTT-II's fitted to my E6.

In the rain/wet when cornering (not at mega speed) I find that the front of the car is twitchy and starts to drift a bit.

I thought these tyres were supposed to be good in the wet, or is it my geometry setup that needs sorting ?
 
G

·
Discussion Starter · #2 ·
Mark

Its probably a combination of tyres and standard geometry settings, aswell as having more power:), thats causing your understeer.
I adjusted my geometry today to -2deg camber 1mm toein front and -1.5deg 1mm toein rear and new SO2s on 18 , just been out in the wet and it feels superb. Also running twin tube LEDA coilovers, 8KG fr 7KG rr uprated front anti-roll bar and grp n bushes where required.

Clive
 
G

·
Discussion Starter · #4 ·
On my tme the so1 tend to loose grip at the rear before the front (well if i give it a bootful). Otherwise grip is awesome. You could try a geometry check. There was a thread about best settings a few days ago i think or go with Marks.

How much did you pay for the tyres as price is often a good indication of perfromance. What did you have before?
 
G

·
Discussion Starter · #5 ·
I don't recall what was on there before, as they were bold when I bought the car and I bought new ones straight away. I paid about £440 for 4 tyres back in January. I have done 13k on them and so far, zero signs of wear. Obviously the downside is that they are crap in the wet. However, I did buy them because of their 'wet' abilities.

I will be getting the geometry sorted in the next few weeks.
 
1 - 5 of 5 Posts
Top