Lancer Register Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,771 Posts
Discussion Starter · #1 · (Edited)
the lights on my car are a bit cack, i've got single piece lamps fitted, is it safe to use stronger bulbs? the lights are plastic and i'm worred about them melting!

thanks.
 

·
Premium Member
Joined
·
9,965 Posts
NO :eek:

The standard wiring between the bulb and the column switch is 0.85mm2 (say 10 Amp max). Two 100W bulbs would be 17 Amp

Result = :flame:

Grant :)
 

·
Premium Member
Joined
·
22,085 Posts
NO :eek:

The standard wiring between the bulb and the column switch is 0.85mm2 (say 10 Amp max). Two 100W bulbs would be 17 Amp

Result = :flame:

Grant :)
would the standard fuses blow first

only reason i ask, was years ago on here, people used to fit 100w H4 bulbs in the 4/5/6 headlights, before the days of 1 piece, and HID conversions, and i dont think there was any problems

I am not questioning what you say, just curious how people got away with it

Stu
 

·
Premium Member
Joined
·
9,965 Posts
would the standard fuses blow first

only reason i ask, was years ago on here, people used to fit 100w H4 bulbs in the 4/5/6 headlights, before the days of 1 piece, and HID conversions, and i dont think there was any problems

I am not questioning what you say, just curious how people got away with it

Stu
The standard fuse is 40A :confused:

I seem to recall fitting 100W bulbs to my V, in 199?, and being disappointed.

With hindsight this would have been due to the voltage drop due to the cable size (this was when no, english**, manuals were available) so no damage occured.

Best option for 'i400 would be to fit a pair of "PIAA "Xtreme White Plus" Bulbs - Fits Evo2-6 (HE303)" from the club shop :) That's what I have on the 6RS

Grant

** I have a Japanese printed manual for Evo IV :confused:
 

·
Premium Member
Joined
·
22,085 Posts
The standard fuse is 40A :confused:

I seem to recall fitting 100W bulbs to my V, in 199?, and being disappointed.

With hindsight this would have been due to the voltage drop due to the cable size (this was when no, english**, manuals were available) so no damage occured.

Best option for 'i400 would be to fit a pair of "PIAA "Xtreme White Plus" Bulbs - Fits Evo2-6 (HE303)" from the club shop :) That's what I have on the 6RS

Grant

** I have a Japanese printed manual for Evo IV :confused:
cheers, i was sure people used to get away with them, and i think i tried them too, though, like you say the results weren't impressive

Stu
 

·
Registered
Joined
·
1,771 Posts
Discussion Starter · #7 ·
the car is fitted with 2 relays now so the wiring should be ok, its the lights that i'm worred about.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top