Lancer Register Forum banner

1 - 11 of 11 Posts
G

·
Discussion Starter · #1 ·
is it just me whos going blind or are evo headlights sh#te. my 5 has worse lights than my 10 year old transit.
anyone recomend an upgraded bulb?.
 
G

·
Discussion Starter · #2 ·
Yes they are pants!!!!!

I simply stuck some 80/100 watt bulbs in and it makes it a lot better. I did exactly the same in my Subaru and the missus Peugoet and have never had a problem with bulbs drawing too much currant.

Steve
 
G

·
Discussion Starter · #3 ·
I agree:( the lights are crap I drive with my driving lamps on all the time in my V

Rosco when you say you put 80/100 in is there any special make or a normal Halfords trip?
 
G

·
Discussion Starter · #4 ·
Riddy, maybe look at the link below which a thread covering the same problem.


http://www.lancerregister.com/cgi-bin/UltraBoard/UltraBoard.pl?Action|EQU|ShowPost and amp;Board|EQU|3 and amp;Post|EQU|968 and amp;Idle|EQU|0 and amp;Sort|EQU|0 and amp;Order|EQU|Descend and amp;Page|EQU|13 and amp;Session|EQU|skeletor.101224530590755

Skeletor
 
G

·
Discussion Starter · #5 ·
Following a recent thread on the same topic , I've stuck some PIAA Platinum super white bulbs( 135/125w drwaing 65/55w) in my VI and they are a good improvement ( but a bit pricey). Next step for this weekend is to put a high power loom on. Did this on my last car and it made a huge difference.

Interested to know if anyone has tried the CIBIE HID replacement kit ( costs something ridiculous like 2 grand from co-ordsport). I suspect this is the real solution , but only for lottery winners !

Al
 
G

·
Discussion Starter · #6 ·
Dragon - Yes just the normal H4 light bulbs go straight in! You can also get 90/130w, but I haven't dare try them just incase they draw too much power.

Steve
 
G

·
Discussion Starter · #7 ·
I`m running 90/130watt Halogens in my Evo6, and have done since December no problems at all so far.Just thought i`d let you know.

In my Subaru i used 80/100 Xenon which actually seemed to be better than these, though i carnt seem to get hold of any a.t.m. :(

100w at 12v is 8.3Amps, if the cable in the evo IS 1mm (which i dont know).then that cable will carry AFAIK about 14 amps no porlems at all.

Please correct me if i am wrong :)

Rich.
 
G

·
Discussion Starter · #8 ·
have to agree,
just put some phillips bulbs i in my dads e6 and have made a great improvemnet, standard wattage aswell im well pleased, bought them at the autosport show got the sidelights and H4's at a very very gud price :D
 
G

·
Discussion Starter · #9 ·
You could always try these:
Mitsubishi (?) part number DLB600472VP Visionplus bulb.

Work for me and no worries about the wiring
 
G

·
Discussion Starter · #11 ·
when i got my 5 they came with piaa bulbs which were crap!! changed them to phillips vision plus which also came with side lights cost about £30 .
 
1 - 11 of 11 Posts
Top