Lancer Register Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
hi guys,

Last week the power steering of my EVO VI broke down. I was in a bend and suddenly the steering did not work properly, it took a great effort to steer...I was lucky that this happend at 40 km/h. I don´t want to imagine what would happen at 250...??!!

The mechanics at my garage found out that the oil-tank of the power steering had a leak.

Is this normal? My car is really new...Last but not least, the garage needs more than 2 weeks to repair the problem, because the parts have to be imported from Japan.

I really love my EVO, but such problems would never happen with my Audi S3...What do you think about this?
 
G

·
Discussion Starter · #2 ·
evo6lx,
Not had a problem with the steering to date, but have your service people tried to get the parts from Coordsport.
They may have the required items in stock, here in the UK.
 
G

·
Discussion Starter · #3 ·
EVO6LX,
Did you have any warning that it was about to stop working?
I've got a terrible intermittent squealing noise coming from (I think) the power steering unit. It's been there for a few months (Evo VI).
Going through the bleed process a few times has not helped. The steering seems to be getting harder.
Did you notice any strange noises before yours stopped working?
 
G

·
Discussion Starter · #4 ·
I would've thought the power steering would be the same as in the shopping trolley models so you'd at least be able to get second hand parts cheap and easily from a wrecker. Most modern cars give warning signs/noises before a lot of things go wrong and I've never had power steering problems on any of the Mitsis I've owned.
 
G

·
Discussion Starter · #5 ·
Mathew:

No, I did not recognised a certain noise...the steering suddenly got very hard.

I think this is really a security problem. I will get in contact with responsibles from Mitsubishi.
 
1 - 5 of 5 Posts
Top