Lancer Register Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
I've recently started experiencing some fuel cut-out problems with my E4 GSR which I think are due to overboost - sudden loss of power under hard acceleration at around 3800 rpm, causing a big driveline shunt and making me wince. Not sure why this has appeared - I've run the car for 10,000 miles with no probs - but a clue could be the fact that I was forced into using 95RON fuel on a trip to Scotland recently as I couldn't find any of the hard stuff. Any ideas??
 
G

·
Discussion Starter · #3 ·
I spent the first year in my Evo4 using 95 Ron fuel with no fueling problems, it ran fine
and was very smooth.
I was then informed by Ralliart that it would be more appropriate to use 97 Ron.
The car runs a bit faster and the car is still smooth with no fueling problems, so
I don't think that this is the cause of your problems, look elsewhere.
 
G

·
Discussion Starter · #4 ·
I had a very similar problem with my old subaru legacy turbo,it was a total engine cut at full chat, i thought it had somthing to do with over boost but it turned oyt to be dodgy plugs.
 
G

·
Discussion Starter · #5 ·
Glen ,

Its a little unusual for fuel cuts on E4s,I just spanked mine around a coarse at a rate of knotts keeping up with E6 RSX,and I have my grommet removed .
I also have a decat exhaust ,but with a silenced mid section [replacing cat] and a blitz filter and VTA dump.
I experience a little lag at times but will rev like billyo to 7500 through gears.
Although I reach 140 mph and rev cut at 7000 dead[explain that one].
No fuel cut .
 
G

·
Discussion Starter · #6 ·
what boost are u running
because it could be the fuel cut in the air flow meter
To fix that problem you need to put in a fuel cut defender
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top