Lancer Register Forum banner

1 - 3 of 3 Posts
G

·
Discussion Starter · #2 ·
Though I'm not too sure, I believe the engine will start running either too rich or too lean. This is because the engine won't be able to detect the proper A/F mixture ratio settings for the combustion.

Maybe you could try using an uprated wideband o2 sensor, like the ones the MoTec uses for tuning though these are comparatively costlier. It is far more accurate though.
 
G

·
Discussion Starter · #3 ·
It will put your ecu into open loop mode where it will not keep correcting the mixture. I ran my Galant VR4 with an intermittent O2 sensor and it made next to no difference - on acceleration the ecu goes open loop anyway when it dumps extra fuel in according to the Mitsi workshop manuals. The ECU learns its best settings as time goes by from the O2 and knock sensor feedbacks so that the fuel and ignition are optimised. Try not to disconnect the battery until you fix it as this will reset the ecu's learnt settings. If you see your fuel consumption changing radically then get a new one fast. If it starts to run too rich it will bugger up your cat. Good excuse to throw it away or get a hi flow one.

Until you get it fixed drive a little bit light footed - just in case.

You don't need a wide band one - the ecu won't be able to process the different signal. Most O2 sensors are pretty crap in that they are very non-linear - they only work well in the small range around stoichometric conditions (14:1 air:fuel kgs) - a wide band sensor (some Hondas) is great if your ecu is designed for it. This why people sell little LED bargraph AF meters with no numbers, just rich/lean, as any attempt to turn the readout from a standard narrow band O2 sensor into meaningful numbers at anything other than stoichometric is crap.

Hope this helps

Al.

PS - are you sure it's the O2 and not another sensor up the spout?
Have you read the fault code?
 
1 - 3 of 3 Posts
Top