Lancer Register Forum banner

1 - 5 of 5 Posts
G

·
Discussion Starter #1
Hi everyone,

I have an Evo 6 RS2, and the running in is done, but something happened (twice, once in 2nd, once in 3rd) when I accelerated from 2000 to 5500. A mechanical bang occured at about 4500 rpm, with a cut in the acceleration. I think I lifted off a bit just before it happened, but I am not sure.
Did this happen to anyone? It scares me a bit, 'cause it could me a big problem...

Regards from France

Tarik
 
G

·
Discussion Starter #2
Hi Tarik
Good to see you on list, I am not sure what the large bang could be so probably best to just monitor it and make a note of the exact circumstances when it happens.On another subject what octane rating is super unleaded in France ? as ours has dropped to 97 ron.

Regards Kevin
 
G

·
Discussion Starter #3
Hi Kevin, good to be here indeed,

regarding the noise, it looks like the same symptoms as the message concerning turbo boost , so maybe it is just a cut in the fuelling causing the engine to break pulling the revs, and thus causing a mechanical bang in the transmission.

In France, we have a 98 RON unleaded, so I guess I lose a little bit less than you in output. I already had an opportunity (last night) to test the handling on a very wet, very dirty, and very bumpy back road (definitely not large), and it is nice to see the car reacting like a real race car (remember, I don't have Anti-Lock nor AYC), so I can control the car on the throttle and left-foot braking, and it reacts really well, though I could not push really hard as the road was really narrow and unfamiliar. Moreover, the headlights are not that good, so at night... I am looking forward to the Nurburgring next week end.
Thanks again for all your advice

Tarik
 
G

·
Discussion Starter #5
Hi,

No, I haven't done any mods to my car, it is as stock. What can I do to check if it is overboost?

Tarik
 
1 - 5 of 5 Posts
Top