Lancer Register Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi just hoping my luck changes to see if anyone with diesel lancer had this problem. I had my abs light come on with abs service required which was intermittent then came on more than was off and my hand brake light with check would come on and go out after couple minutes.

Plugged computer in and was codes u0121 and u0415 which looked like the abs pump, had it sent away to check over which they called to say was all working fine but before they checked it they called to say was small transit damage on plastic (to me looked like been dropped as was well wrapped) but again said test was fine damage didn't effect unit.

Abs pump back in brakes bled drove car home and still have abs light still on now with the hand brake check light staying on and with few more eng man and glow plug light flashing and when staying with hand brake on having a beep saying release hand brake as if im driving with it on plus speedo not working.:mad:

Anyone had this problem any help be greatful
 

·
Registered
Joined
·
144 Posts
Hi just hoping my luck changes to see if anyone with diesel lancer had this problem. I had my abs light come on with abs service required which was intermittent then came on more than was off and my hand brake light with check would come on and go out after couple minutes.

Plugged computer in and was codes u0121 and u0415 which looked like the abs pump, had it sent away to check over which they called to say was all working fine but before they checked it they called to say was small transit damage on plastic (to me looked like been dropped as was well wrapped) but again said test was fine damage didn't effect unit.

Abs pump back in brakes bled drove car home and still have abs light still on now with the hand brake check light staying on and with few more eng man and glow plug light flashing and when staying with hand brake on having a beep saying release hand brake as if im driving with it on plus speedo not working.:mad:

Anyone had this problem any help be greatful
There aren't many Lancer owners on here, particularly diesel owners. I run a Facebook group which you are more than welcome to join. Search for Mitsubishi Lancer UK (Non Evo)
Plenty of diesel owners on there.

With regards to your faults I'm unsure what the problem is other than perhaps check your ECU for water ingress, particularly if you've had water in your engine bay, such as a engine bay detail.

The car will beep if it thinks the handbrake is on.

Sent from my SM-G920F using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yeah having that feeling it is my ECU but engine never gets detailed so shouldn't have water damage. Might need to bite bullet and put into Mitsubishi :wallbang:
 

·
Registered
Joined
·
144 Posts
Yeah having that feeling it is my ECU but engine never gets detailed so shouldn't have water damage. Might need to bite bullet and put into Mitsubishi :wallbang:
If you were happy to do it, I might be able to send you my old ecu for you to try. Mine old one is faulty due to water ingress and gave crank shaft sensor codes as a fault. So if it didn't give you your current faults then it would prove the ecu.

Sent from my SM-G920F using Tapatalk
 
1 - 4 of 4 Posts
Top