Lancer Register Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Firstly, When I test drove the car it was fine, as was taking it home. However, after taking it (slowly) through a series of tight corners, the AYC lamp came on. It now stays on intermittantly. I went for a spirited run in the hills and there was no 'squawking' from the rear. In fact, it handled like no car I have driven (previous sports cars i've owned are GTiR, FD RX7, BMW 325). The light doesn't seem to come on or stay on for any particular reason (eg on hard cornering). Its completely random. I just got back for a drive now and didn't come on until I pulled into my parking space. Any ideas???

Secondly, the brake calipers have that common problem of the laquer chipping and the colour fading. Has anyone tried respraying their calipers with high-temp paint? The Brembo logo appears to be a sticker between the paint and laquer, do you know if I can get new stickers?

Thirdly, the common tappet noise exists on start-up but is much quieter when warm (but still noticeable). Should this be a cause for concern? I don't know what grade oil is in it but it is very clean and the level is a bit high (although, the car was still warm when I checked it). Is this something I should just live with?

Thanks in advance for any advice
 

·
Tarmac Tyre Shredder
Joined
·
14,541 Posts
tappet noise will 99% be lash adjusters (do forum search for more info) changing oil might help but most common is to replace them,or if your skint,but good with tools,clean them out.uprated lash adjusters are about 200 quid,but they do cure the noise.
As for the AYC light,your car might want to go on the mitsubishi MUT equipment to trace the trouble code.silly question but is there enough AYC fluid in the pot.
 
1 - 3 of 3 Posts
Top