Lancer Register Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter · #1 · (Edited)
help! Losing my mind! MISFIRE!!--SOLVED!

Just changed plugs hoping it would solve my misfire problems, it was ok for a while but it turns out it still misfires like It did before I have changed the plugs. Im losing my mind. Can you list down all the possible causes of this problem so I can check them one by one? Thanks in advanced and hoping for you help. Badly needed.

just some info, I recently broke my boost controller and my car is running 0.5 boost (0.9 is standard i think) recent plugs were denso IW22s changed to brand new IW22s again. Cant find standard plugs. CAr is evo4 rs. Just fitted apexi filter together with heatshield before the misfire became really noticeable.
 

·
Registered
Joined
·
7,349 Posts
plug leads......
try ngk BR 8es plugs......will work well


(worse case scenario....blown head gasket)
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #4 ·
ok ok, Im a bit lost, What is the difference between leads and coil packs? I see them alot here but I cant figure out the difference. Anyway could it be that my low boost is causing the car to overfuel?? Could it also be loose hoses?
 

·
Registered
Joined
·
7,349 Posts
Jay
coil-pack = current equivalent of the old style 'coil'
& not the same as plug leads (!) which come off the coil pack to your plugs

low boost will not cause car to over-fuel
if you think this is happening....take it to a good garage that has
* wide-band lamda sensor testing kit
* fuel pressure testing kit

check all pipes everywhere to make sure they are secure, don't have any holes etc

where are you based...would help to know , so as to suggest a specialist nearby....
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #6 ·
Thanks mate! Now the question, sometimes my idle is bad, I could see it on my vacuum gauge, the reading fluctuates. Anyway could it be that loose pipings are causing the misfire?? How about the ol' fuel filter?? I wish I was based somewhere in the uk but im not, Im in the philippines and the nearest specialist is 250kms away from where I am. hehehe!
 

·
Registered
Joined
·
1,703 Posts
JAY986 said:
Im in the philippines and the nearest specialist is 250kms away from where I am. hehehe!
well , at least you have a specialist .... we dont , when i have a problem with the car its me , the car and my dumb mechanic :D .
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #8 ·
good one hashash! :D Ever heard of turboawd? I think he is a lancerregister member. He owns the specialist shop I think. Well we are just the same. 250 kms away would mean when I have a problem with my car, its just me my car and my dumb mechanic too. hehehe!
 

·
Registered
Joined
·
710 Posts
..blocked injector ?

Do Evo's not have an OBD MIL light ? A misfire should definitely illuminate the MIL light.

A diagnostics check would then identify exactly where in the Emissions control system the failure is.
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #10 ·
I remember the check engine light went one once during going through the gears before. hmmmm.... then once again just when I was about to stop to clear a hump. Funny, never happened again though.
 

·
Registered
Joined
·
160 Posts
Discussion Starter · #11 ·
PROBLEM CURED! hehehe! Turns out the rubber hose connecting the turbo to the intercooler had a big hole in it and was partially melted. Had it replaced and it runs like a dream now.
 
1 - 11 of 11 Posts
Top