Lancer Register Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
20,560 Posts
Discussion Starter · #1 · (Edited)
Sorted a heater control valve issue about 18 months ago iirc , it was sticking so was either stuck cold or on hot postion .....
This eve i had evo idling for 10 mins as i faffed about with the new "go pro" camera ...had air con on to demist faster as it was frosty here all day ! Turned off that and noticed air wasnt as warm as it should be either way ....turned dial to cold ....then back to warm ......stayed cold !
Thinking its this control valve sticking i drove off and pulled in few mins later ......turns out the valve moves ok , yet still bloody cold air only !
Doesnt matter what postion ,face/windscreen etc or dial temp etc .......
Temp guage normal and plenty of coolant in expansion reservoir !
Left it at that after a spin , too dark n cold :angel:
Heater matrix fubared ? Will find where the pipes are behind engine going through bulkhead and see if they heat up with car running the next time im free over few days .......Ideas welcome ! :handsup:
This is heater control valve left of clutch pedal thats not the issue this time ;
 

·
Premium Member
Joined
·
939 Posts
If you move the white plastic bit manually by hand, does it affect temperature?

I had similar issue where the arm connected to the white bit had fallen off so wasn't moving the white bit.
Maybe the motor that moves that bit is burnt out? As yours looked connected from the picture.

Edit: sorry, re-read and you say the white bit moves ok. Probably not that then
 

·
Premium Member
Joined
·
20,560 Posts
Discussion Starter · #3 ·
If you move the white plastic bit manually by hand, does it affect temperature?

I had similar issue where the arm connected to the white bit had fallen off so wasn't moving the white bit.
Maybe the motor that moves that bit is burnt out? As yours looked connected from the picture.

Edit: sorry, re-read and you say the white bit moves ok. Probably not that then
:mhihi:
Oft worth re reading my posts twice or thrice to comprehend :lol:
Havent had time today , though i would this eve but many things conspired against me ...
Will check over what pipes are hot or not next week , as heading away from home with verk tomorrow :cry:
 

·
Premium Member
Joined
·
824 Posts
Have you checked the radiator pipes were hot and you haven't got a dodgy thermostat etc if your car has been frozen all day
 

·
Premium Member
Joined
·
3,274 Posts
I'm a mechanical moron but I thought thermostat aswell mate . Hope u get it sorted always when u need it ay
 

·
Premium Member
Joined
·
20,560 Posts
Discussion Starter · #6 ·
Have you checked the radiator pipes were hot and you haven't got a dodgy thermostat etc if your car has been frozen all day
Didnt check on that evening ....but stay tuned to my next ramblings :mhihi:

I'm a moron
Dont be too hard on oneself :D
I digress :angel:
On my return home late last night , from verking abroad since Thursday (Waterford is abroad :rolleyes:)i decided to check her over later today......air flow was tad warm after a while ....but still not what it should be ! Pipes through firewall seemed warm ....upper rad pipe hot , lower hot but tad lower temp it seemed...i gave that one a good squeeze
I went for a spin to give the "aul gal" some exercise ,
pulled in to forecourt and checked all again .....
Then after a minute the temp went to normal hot air as it should be ....messed about with dials to cold/hot and directional flow ...all seems fine now .....maybe a glitch in the "matrix" ;) , yes Mr Anderson :mhihi:

 

·
Premium Member
Joined
·
20,560 Posts
Discussion Starter · #8 · (Edited)
What's going on in the last pic will..looks like a pipe missing/come off
Dodgy pic is all lol ....thats my custom made water pipe ill have thee know :angel:
Havent driven her all week , but last weekend i had same issue again .....luke warm air and if i turn to cold then back to hot it stays cold .....control valve is moving !! Wonder if its not connected properly to the innards ....worn gears ( if there is gears inside moving the "blend" door?) ....time for grinder shortly methinks , if i had bloody time with uber busyness Arbeit macht frei spec n all


This may not help lol :
 

·
Registered
Joined
·
233 Posts
Yes!!!! It's grinder time ��

On a serious note....I've no idea what's causing the problem ��
 

·
Premium Member
Joined
·
824 Posts
Dodgy pic is all lol ....thats my custom made water pipe ill have thee know :angel:
Havent driven her all week , but last weekend i had same issue again .....luke warm air and if i turn to cold then back to hot it stays cold .....control valve is moving !! Wonder if its not connected properly to the innards ....worn gears ( if there is gears inside moving the "blend" door?) ....time for grinder shortly methinks , if i had bloody time with uber busyness Arbeit macht frei spec n all


This may not help lol :
For what it's worth will maybe just change thermostat for the sake of 10 mins..surely rule that out before attacking the heater matrix
 

·
Twincharger Guru
Joined
·
4,546 Posts
On the 5/6 there's a corrugated plastic pipe that connects to the temp knob. If it falls off there is no heat. I'm unsure if the Evo 7 has the same setup? Easy to check by pulling the fascia off for a look
 

·
Premium Member
Joined
·
20,560 Posts
Discussion Starter · #12 ·
Yes!!!! It's grinder time ��

On a serious note....I've no idea what's causing the problem ��
Damn you :rolleyes::lol:

For what it's worth will maybe just change thermostat for the sake of 10 mins..surely rule that out before attacking the heater matrix
Might do that as ive spares ....yet i think its something amiss with the blend door (or doors ?) as this eve i kept moving from cold to hot settings .... it will get hot enough , not quiet as hot as it should though ,and if once hot i dont mess wih dial it stays hot ......put to cold then back to hot and it tends to stay cold :lol:

On the 5/6 there's a corrugated plastic pipe that connects to the temp knob. If it falls off there is no heat. I'm unsure if the Evo 7 has the same setup? Easy to check by pulling the fascia off for a look
Different set up on this methinks :thumbup:
 
1 - 12 of 12 Posts
Top