Lancer Register Forum banner

1 - 9 of 9 Posts
G

·
Discussion Starter · #1 ·
Hi!

I've got my boost pressure measured and it looks normal,1.2bars max.

The cuts still there in 4th and 5th gear at around 6000rpm.http://www.ltregister.f9.co.uk/graphics/sad1.gif border|EQU| 0 align|EQU| absmiddle >

Suggestions???
 
G

·
Discussion Starter · #2 ·
What sort of modification have you done on your car?

Sounds like over boosting, or it's not over boost just your ECU think the car is over boosting..check your setup
 
G

·
Discussion Starter · #3 ·
My Evo v rs has a full supersprint exhaust pe fuel pump and hks rs kit.

The solenoid restrictor still in place and I removed the one near the waste gate to decrease boost.

A few months ago there was a post from Adrian saying that he ordered a hks fuel cut defencer to stop the fuel cuts.
Any news?
 
G

·
Discussion Starter · #4 ·
Check the wastegate actuator diaphragm for leaks. They are mounted vertically on the Evo and are under the bonnet vents allowing rain/moisture to sit inside them. Mine had this problem. **** UK weather.
 
G

·
Discussion Starter · #5 ·
Hi Evo driver!

Where is exactly the wastegate actuator diaphragm(near the wastegate I guesshttp://www.ltregister.f9.co.uk/graphics/happy1.gif border|EQU| 0 align|EQU| absmiddle >)?

If this is the problem can it be fixed or do you have to change parts?

Thank you for your help!
 
G

·
Discussion Starter · #6 ·
Maxi,

Look at the wastegate. The diaphragm is inside the circular cylinder at the bottom end of the rod and is used as a release valve when turbo pressure mounts up (the rod just pulls out, letting pressure escape or something like that!). Easily tested en situ by anyone with a simple pressure pump/gauge set-up. My problem which caused overboost was simply that the diaphragm was unable to hold pressure and therefore just cranked up the boost until the ECU cut the fuel in a big jolt-like fashion! You'd need a complete new actuator which Ralliart have in stock I believe (how convenient!).
 
G

·
Discussion Starter · #9 ·
Had my actuator changed.

The old one had rust on it and the the diaphragm was worn out.

Firstly we try to replace the 0,5mm restrictor,but it was cutting again.
With the restrictor removed I've lost some acceleration but no fuel cuts at all.

I'll try to replace a restrictor soon but with bigger hole.And maybe I'll go for the ralliart ecu,it makes a real improvement!!!
 
1 - 9 of 9 Posts
Top