Lancer Register Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone,

I am from the USA, and we are not real familiar with the Wastegate actuator from Forgemotorsport. However I purchased it from Orlando, FL recently on put it on my 2003 Evo 8 to put more load on the wastegate. My stock wastegate without boost controller is 11 psi. When I put the forge piece on It now is around 14psi. I compensated my MBC to adjust 20psi. My question is why does the car no longer spool at 3500 rpm 20psi. The car feels slower until 4000rpm and then takes off to redline.
Who ever is using the piece in the UK, can you tell me your experience with this piece? The car with the stock actuator feels entirely different. I would appreciate anyone help who has this on there car.

Thanks

Steve


__________________
2003 EVO 8
Rio red, modded with tuboback system, SAFC2, FMIC, lower, upper piping, Aperture, Tuned
320whp on Dyno

New mods: Forge Adjustable Wastegate actuator.
 

·
Registered
Joined
·
2,295 Posts
how much preload did you put on the arm when you fitted it?

you need at least 1/2 to 3/4 of a hole.

mine gave much better performance than the OE one.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for your reply. I actually went out and played with it yesterday and finally found the perfect pre-load. When you press on the throttle it feels like there is more vacuume. However, I was able to make adjustments with the MBC under the hood now. I can definately tell it pulls harder the higher the rpm. Before it felt like it would fall off or you would have to floor the gas pedal. I believe the arm is 3/4 of the hole and works well.

Steve
 
1 - 3 of 3 Posts
Top