Lancer Register Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
Hello chaps
Is it ok to use flushing oil on an evo 6 engine when changing the engine oil?. My friends 6 rattles very slightly when cold from the top end for a minute or so. I thought i would change the engine oil after using flushing oil then use a md356000 oil filter as mentioned in a previous thread to see if this would cure the problem. I would use Mobil 1 motorsport oil but any suggestions or experiences would be greatly appreciated.
Regards, SIMON.
 
G

·
Discussion Starter · #2 ·
Does he park with the car on a slope at all?
This causes the oil to empty from the lifters giving noise on startup but disappears when car is warm, common fault on most mitsi's. Not a big problem if it clears within a minute.



Tony
 
G

·
Discussion Starter · #3 ·
In my opinion forget about the MD356000 on the E6, I will not be using it again as it's just a waste of an extra £5-£6 and I have had no problems with MD322508.
Sorry I should have posted about it before as I have chopped up both filters in question, MD356000, the so called correct one and MD322508 the one Mitsubishi garages use and there is virtually no difference between them. Actually the MD322508 has a 17% larger filter surface area than the MD356000 so you could say it was a better filter.
I will post my findings later.
As Tony says tappet rattle for a minute or so after cold start up is not a problem and is nothing to worry about. It's the nature of the beast.
Use flushing additives if you want too, personally I don't bother.
 
1 - 4 of 4 Posts
Top