Lancer Register Forum banner
1 - 10 of 10 Posts
G

·
Discussion Starter · #1 ·
My E7 showed the engine warning light within 5 miles of collection from my importer. This was traced to a transient fault in the EGR system by my local Mitsu dealer, who reset the warning off , but the warning appears again after about 5-10 miles. There is NO technical information on the 7 available from Mitsubishi UK for the 7, so I am waiting for info from Japan. Can any one out there help?- especially if you are in Japan and have contact with a Ralliart dealer who may understand (or has seen?) the problem before. Thanks!
 
G

·
Discussion Starter · #2 ·
Japanese domestic market lancer evo V11 has now adopted a manifold differential pressure sensor which detects the changes in pressure inside the intake manifold caused by the opening and closing of the EGR valve. The EGR system fault you describe would suggest the failure of this (MDP) sensor and therefore requires replacement, suggest dealer checks MPI data list using MUT Tester to varify operation (providing they have the upto date ROM pack).
 
G

·
Discussion Starter · #4 ·
Well Hard -whatever , if that is your considered comment on this subject, it unfortunately confirms my worst fears about who is out there......If you are a moderator then I think you should be more constructive in your reply; or do you work for CCC? and have a vested interest in official imports.I also don't like to be patronised as your friend . If you feel like an agressive reply,just close the thread cos' life is toooooo short.Cheers!
 
G

·
Discussion Starter · #5 ·
actEVO,
sorry to hear about your car problems. However, I can see where R and amp;AHP is coming from. Buying a car that isnt officially available here, is going to cause problems when you need technical support, because nobody will know anything thing about it. UK Mit. dealers know very little about the E6's (let alone E7's), their training is limited to basic servicing and plugging the MUT in. In situations like this I would recommend a specialist; I use BTRPrep who prep Evo rally cars, but I expect even they will struggle as they wont have seen many E7's if any.

I can assure you R and amp;AHP has no connections to either Ralliart or a vested interest in imports (to my knowledge). Incidently I have an import E6.
 
G

·
Discussion Starter · #6 ·
I'm with actevo on that one. That was a real patronising reply. He didn't come to this great forum to ask what car to go and buy. He came for some advice to help with the problems he has encountered with the car he has bought. He came to a place where everyone else should be similarly interested and sympathetic. Forums like this exist to help people drive cars that are different to all the other tinboxes out there. Exist so that we can get together to exchange information and opinions and help each other out. I hope he gets an apology - I'm appalled that a 'moderator' recommended not to buy an evo.
 
G

·
Discussion Starter · #7 ·
Actevo,
You have just had a little bad luck. Take it into Ralliart or your import people to sort it. I have been running an Grey E6 now for 1.5 years ,47k miles and have had no major problems.

Keep buying grey/parallel ! The official importers will have to bring their 'over-priced ' prices down.
 
G

·
Discussion Starter · #8 ·
Thanks Lightspeed for your support!
Update--The original Japanese dealer has identified the MUT error code (PO 400) as a problem with the EGR Vacuum Valve and is even sending me a FOC replacement, even tho he has no warrantee obligation to do so. Thats what I call good service!!
I am sure I could have found the same diagnosis in the UK, if, (IF!), the MUTs in UK had been updated--but as I have said elswere, the Evo7 seems destined for a 2002 launch in UK so there appeares to be little incentive for CCC to update RalliArt dealers before then, and they will therefore struggle to service Evo7s as a result.
Does anyone out there have access to an updated MUT??
While I would admit this is not an ideal situation to be in, re:servicing a complex piece of kit; I will have enjoyed my E7 for 7 months by the time the first officials arrive and I am sure this is no worse than when ALL Evos were grey--remember??!
 

·
Registered
Joined
·
33 Posts
Ok this is a really old thread but im having the same prob anyone know what i need to do to fix my car with a EGR system fault reading from my ecu ?
 
1 - 10 of 10 Posts
Top