Lancer Register Forum banner

Evo x u0151 no comms with restraints module

1091 Views 8 Replies 3 Participants Last post by  Panther
Can anyone help me with this as I'm at the end of my tether with it.

Basically car was supposed to go in for gear linkage change as one cable got damaged. Due to the lockdown I decided to change the gear linkages myself.

Since reinstalling everything I have a srs airbag warning and dont know where to look for the fault anymore. To do the linkages I had to remove srs ecu then plugged all back togeather but now have this code.

I have tried clearing it with ecutek cable but it keeps coming back. I have tried to plug in another srs ecu and get the same no comms.

Does anyone know where the fuse maybe for this... everything is connected and wiring seems fine visually.

Any help would be greatly appreciated.

1 - 5 of 9 Posts
Hi yes the 2nd hand ecu was same part number and had no crash data so a working unit. I know I would have to pair it to my vehicle using a Mut3 to calibrate the vin and srs ecu togeather. However tested it to see if there would be communication but still got same code.

I did indeed follow all steps inc disconnecting the battery during any work.

I just cant see what unplugging it then replugging it has caused :blah:

I wonder if only a mut3 can clear and diagnose srs fault... I've really looked at everything I possibly can and am left baffled with it.

Thanks for reply :thumbup:
..... post removed as link I was trying to share wouldnt work
As far as I know, if the battery was disconnected for the duration of the time the srs ecu was disconnected, then no fault code should have appeared.
I believe the same... a fault must be present that wasnt before but I cant understand what's caused/causing it. I'll have to get it to a specialist who is competent in electrical fault finding and has a MUT computer.... just was hoping maybe someone would have some things for me to check or try as lockdown wont end for a while still.
That's funny thing everything seems fine... and indeed its properly grounded. I think the CanBus will need diagnosing with mut3. Thanks for replies
1 - 5 of 9 Posts