Lancer Register Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
I've had my Evo X 330 for just over 6 months now.

I've always had a little problem getting it into reverse but hoped it would get better with miles. I'm not exactly technical so I'll try my best to explain what the problem is :

If I've been driving and stop to reverse there seems to be a period where the car will rev quite high (car not moving) while I try to put it in reverse (clutch right down with no acceleration). It can take a few attempts before it finally goes into reverse. There's no noise or anything just a struggle to find reverse. Last week I happened to look in my rear view mirror while trying to get it in reverse and noticed a puff of smoke coming from the back.

I can live with it for the moment but it's beggining to annoy me.

Any ideas ?
 

·
Premium Member
Joined
·
12,346 Posts
I would speak to the dealer as I have never experienced this.

Regards,
GUM
 

·
Premium Member
Joined
·
1,936 Posts
I would speak to the dealer as I have never experienced this.

Regards,
GUM
Nor me reverse is just as difficult as any other gear :lol:

get onto the dealer sounds like an abnormal problem
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #5 ·
OK Cheers Guys, I'm off work this week so an ideal time I guess for a trip to the dealer.
 

·
Registered
Joined
·
45 Posts
Evo X

my evo x is fine in reverse , I would go and get it checked out at dealer ...:)
MY evo x is a bit of a hand full on bumpy country roads .so i switch of traction control off this seems to sort it out till i get on a bit better road ,has anybody found this ?? or am i driving it to hard ???......
 

·
Premium Member
Joined
·
10,231 Posts
Think the irrational rise in revs is a standard feature of the mapping on these cars, mine does it and it's embarrassing at times, often happens when you are maneuvering or reversing.
Mine only does this with the A/C turned on, so it's usually off these days :)
 

·
Premium Member
Joined
·
20,180 Posts
my evo x is fine in reverse , I would go and get it checked out at dealer ...:)
MY evo x is a bit of a hand full on bumpy country roads .so i switch of traction control off this seems to sort it out till i get on a bit better road ,has anybody found this ?? or am i driving it to hard ???......
Do you mean you just turn the first stage off? 'cos thats only the ASC (which is just the brakes?) I've only had that cutting in on corners or sharpish bends.
 

·
Premium Member
Joined
·
12,346 Posts
MY evo x is a bit of a hand full on bumpy country roads .so i switch of traction control off this seems to sort it out till i get on a bit better road ,has anybody found this ?? or am i driving it to hard ???......
Traction control will normally dispaly on the console if it is being activated... I normally turn it off on country lanes but forgot a couple of times and there is no difference unless you get sideways and then the traction kicks in. This will show on the console with an image of a skidding car and normally cuts the throttle:blah:

Your problem also sounds odd... car loves country lanes more than any other:mhihi:

Regards,
GUM
 

·
Premium Member
Joined
·
10,231 Posts
Get into car, start engine, press and hold traction control button for 5 secs or so, you hear a ding, dash screen turns yellow, drive off and enjoy........:)
 

·
Registered
Joined
·
270 Posts
I've had it happen once or twice on the evo, and a handful of times on different cars.

If it doesn't go in, Simply try engaging abother gear (say 1st), and then try again putting it into reverse. Always works for me.
 
1 - 14 of 14 Posts
Top