Lancer Register Forum banner

1 - 20 of 28 Posts

·
BooooooosT
Joined
·
126 Posts
Discussion Starter · #6 ·
I have a plug hanging down from the look under both areas where the speakers go but it doesn't look as if it's the same figment for the plugs?
 

·
Premium Member
Regional Organiser
Joined
·
6,843 Posts
I got a set of these from MrBlobby's rally car and they fitted straight in and connected up to the existing car wiring loom plugs. :smthumbup

Car (V/VI)is designed 'fitted for'. The 'spare' connectors are obvious once you see them.

Do you have/want the plastic covers for over the top of them too?
 

·
BooooooosT
Joined
·
126 Posts
Discussion Starter · #10 ·
I got a set of these from MrBlobby's rally car and they fitted straight in and connected up to the existing car wiring loom plugs. :smthumbup

Car (V/VI)is designed 'fitted for'. The 'spare' connectors are obvious once you see them.

Do you have/want the plastic covers for over the top of them too?
Put up some pics of them and the plugs and il see if they are the same. They are not pink and yellow are they? Haha
 

·
Premium Member
Regional Organiser
Joined
·
6,843 Posts
Put up some pics of them and the plugs and il see if they are the same. They are not pink and yellow are they? Haha
If you get the speakers off that other bloke the car wiring should just plug straight onto the connectors in the picture. UNLESS previous owner(s) have messed about with your OEM wiring loom :handsup: I'ts obvious once you see them.

I've only got the covers not mint (one screw got pushed right through it) but once fitted you would never know:
 

Attachments

·
has a Carbon fetish
Joined
·
2,890 Posts
I've got covers and speakers. Sitting in a 5 breaking at the moment. £50 delivered


Sent from my iPhone using Tapatalk
 

·
Premium Member
Regional Organiser
Joined
·
6,843 Posts
I thought you were getting the OEM speakers off Mitzi5 bud?

If you do I will let you have the covers mate just pay me for postage :smthumbup
 
1 - 20 of 28 Posts
Top