Lancer Register Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
569 Posts
Discussion Starter · #1 ·
well at least i think so, i've just finished rebuilding it, I run it for 200miles and thought i'd accelerate see how it was but just knowing my own car it feels down on power not pulling as hard if anything i thought it would be better as i've stripped and rebuilt the head and cleaned everything up there seems to be a noticable turbo suction noise louder than before perhaps a leak from the dump valve? i'm just guessing
any ideas will be appreciated, might be something i over looked cheers
 

·
Premium Member
Joined
·
7,656 Posts
check and make sure all boost and vacuum hoses are all on and tight check for splits etc.did you have intake manifold off from the head?
 

·
Registered
Joined
·
569 Posts
Discussion Starter · #3 ·
yes both manifolds were taken off
 

·
Registered
Joined
·
870 Posts
I had the same problem the other week on my E6, checked all kinds and it was making a noticebly different engine noise and felt low on power.
Turned out to be the vacuum hose to the dump valve, on first inspection it looked fine, but when I removed it, it was slighlty perished on the bend and was leaking there!!

Good luck mate :D
 

·
Registered
Joined
·
569 Posts
Discussion Starter · #5 ·
ok cheers mate i'm looking to colour coodinate the engine so i might replace all vacuum hoses emiminate them all
 

·
Registered
Joined
·
569 Posts
Discussion Starter · #7 ·
the car seems to stutter at low speed driving and the revs are a bit random is this classic signs of an air leak?
 

·
Registered
Joined
·
186 Posts
Did you use new gaskets when refitting inlet and exhaust manifolds? I didnt replace the inlet gasket on mine and it ran like a dog until i put a new one on. Start the engine and spray some carb cleaner around said areas to check. Engine tone should change.
 
1 - 9 of 9 Posts
Top