Lancer Register Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
folks

my car was up for its first MOT yesterday ... anyways got home and car was completely dead ... all signs of a flat battery :shake:

used the jump leads and as soon as positive went on terminal alarm chirped and i then turned on the ignition and cranked her over ... happy days ... no probs ... :smthumbup left her running, done a quick wash underneath with the power hose took her for a quick blast ... everything sweet. called back at house, turned her off, left her 10 15 mins then went and got petrol and then bombed onto the test centre ... again everything ok :smthumbup

arrived at the test centre, as soon as i parked the car (did not switch off) the EMS light emitted on the dash :mad: ... my heart sunk :cry:... anyways still on after passing MOT and sitting over night, drove her into work this morning, no sign of loss of power etc seems to be driving normally but light is remaining on :confused:

any thoughts on what it could be?

any reason re jumping the car?

just a bit worried about her tbh, and i am one of these people who cannot stand lights being on, on the dash ... total distraction :eek:

no problems in 3 yrs of ownership and now this ...

do u think a reset will cure all ills?

thoughts much appreciated on possible problem/remedy

thanks
 

·
Registered
Joined
·
19,543 Posts
Get the fault code read by Mitsi, or ground out pin 1 on the OBD port and count the flashes the lights on the dash make. Long flashes are 10's and short ones 1's.
The CEL could be any number of faults, without checking it could be anything.
 
1 - 3 of 3 Posts
Top