Lancer Register Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
i have a turbosmart dumpvalve fitted to my 9.everything fine when you boot it but when driving along normal any touch of accelerator you get a fluttering sound .is this ok cheers
 

·
Registered
Joined
·
1,145 Posts
The fluttering noise is basically your DV not opening (possibly because of a tight spring) therefore the air has no where to go and heads back down towards the turbo. The fluttering noise is the turbo blades chopping up the air
 

·
Registered
Joined
·
580 Posts
Sorry for the n00b question but the previous owner(s) of my 8 have fitted a dump valve but left me with no spare parts. What would I need to put it back to standard .... and is this something that's advisable or not? I appreciate the benefits of it but absolutely hate the noise it makes!
 

·
Registered
Joined
·
1,145 Posts
You will need the standard recirc DV. It then connects to the intake pipe and the intercooler pipe and there is a small vacuum pipe that runs to the inlet manifold
 

·
Registered
Joined
·
1,302 Posts
was just goin to make a thread on this, i also have turbosmart, which is fine...but i am wanting a re-circ valve to get the anti-lag to work....
Which re-circ valve should i use?? E8, Mr turbo @1.6 bar???
Cheers Steve

Hope u dont mind me hijacking ur thread a little:smthumbup
 

·
Registered
Joined
·
1,302 Posts
it is a VTA, not a dual port, have read that a standard mr re-circ is ok, but wasnt sure.
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #10 ·
The fluttering noise is basically your DV not opening (possibly because of a tight spring) therefore the air has no where to go and heads back down towards the turbo. The fluttering noise is the turbo blades chopping up the air
is this bad
 
1 - 10 of 10 Posts
Top