Lancer Register Forum banner

1 - 20 of 87 Posts

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #1 ·
I am now well on my way to getting my original DBA install back from my evo 8 days installed in my second 9.

I never bothered fitting it to the blue 9 as I was edgy knowing that the blue car just wasn't right for me.

Despite always toying with the idea of selling the car, if this one ever goes, it won't be another 7/8 or 9 that replaces it, so I can safely say that the audio system would go with it.

Hence, no fear about installing it only to remove it.

I am far from fininshed with the reinstallation but the hard bits are out of the way.

rear speaker double adapter brackets and rear speakers are in, and no fouling on the boot lid springs on this car - yay!

sub board is in, front tweeters are in and nicely hidden behind the OE panels.

All wiring in and routed except for the power cable which will be done for me when the guy comes to install my reversing camera.

Then I just need to connect up the amp and rear speakers, plug the adapter speaker loom into the standard loom behind the dash and install the front speakers - easy bit!

Here is where I have made one change with Danny's approval.

I switched the supplied amplifier for a Phoenix gold ZX450, a, because I always loved the amp, and b, because I thought it might improve the control. Danny put the original set up together with a budget in mind, and since I had this already, the budget considerations were less important.

The only question would be whether or not the amp would fit in the same place.

Here is the result.



ignore the cable ties, i haven't cut them yet!
 

·
Registered
Joined
·
3,154 Posts
How does it sound???
 

·
Registered
Joined
·
2,277 Posts
looking good - big ******* the zx450 :coolsm:

Much difference in sound quality??
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #4 ·
did nobody read what I wrote? :(

It isn't working yet, but last time I heard it, it sounded fantastic. Should be even better with this amp!
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #7 ·
rob,

I get pioneer equip for about 60% of trade price.

I had the screen anyway and so thought why not, it cost me like £40.

and it isn't just for reversing, you can leave it on on track days for your passenger.

Plus, don't deny that the rear wing makes it harder to park.
 

·
Registered
Joined
·
14,954 Posts
Adam, you write this:

rob,

I get pioneer equip for about 60% of trade price.

I had the screen anyway and so thought why not, it cost me like £40.

and it isn't just for reversing, you can leave it on on track days for your passenger.

Plus, don't deny that the rear wing makes it harder to park.
I read this:

"Does it matter that my Evo doesn't match my handbag?"
;) :lol:
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #9 ·
you mean your evo matches your handbag? :gay:

at least I am man enough that I don't mind a slight clash.
 

·
Registered
Joined
·
3,154 Posts
Reverse cam is a good idea. I could do with one but can't be asked to strip the damn car again!!!
Having 2 would be ideal! One for front and one for back! The kids would love that - seeing ahead...

Hmm 60% off...
 

·
Registered
Joined
·
5,633 Posts
By'ell i've been out the country for most of the week and i return to named threads, 2 of 'em :blush: i don't know what to say but thanks :eek: :D

Looking good Adam! the PG will rock, i have a good feeling that static you'll get a good deal more detail (a good % of which will be lost with the car in motion) in the mid to high region, especially through the ceramic coated alu tweeters, a lot less harsh than Titainium and should suit the char. of the PG. The fun will be in the lo's, PG's are known to be a tad bold in this region, BUT thats why they are sought after and hold a good market price and share.

Pump-Up-The-Jam :smthumbup

...as far as handbags, i can't comment (honest ;) )...but clashing, i am somewhat of a self confessed expert, i've been a ginga all my life and have only clashed with everything so far!!!:wallbang: :mhihi:

Njoy all,
danny.
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #12 ·
can't wait to power it up, if only I could get my alarm guy to come over and fit the power cable he owes me.

Can't be arsed to do it myself, it isn't pleasant as it has to go through the wheel arch liner.

Once inside the car it's easy.

Sohail,

Didn't think of forward facing the thing, not sure I could hook that up so easily.

The rear view one also comes on automatically when reversing, but can be switched to on purpose if you want. I thought that would be cool for track, that or the g-sensors that the pioneer lets you display.
 

·
Registered
Joined
·
3,154 Posts
I can add 2 cams. An infra red front cam would be cool!
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #15 ·
I suppose I could add a front facing cam to the auxillary input. I suppose the rear cam input is specific to switching when reverse gear is applied.

Maybe we should look into some night vision cams!
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #16 ·
connected up the amp finally today.

PG zx450. and.......NOTHING.

Can't figure it out, PG is showing power everything connected as it should be but no sound.

I went to bed totally frustrated and decided this morning to strip out the whole system and just run the DB front speakers off the head unit and some other kind of rear speakers.

This morning I refitted the headunit after taking it out to check the wiring and suddenly it works.

No explanation, nothing changed it just works.

Sadly I haven't connected the rear speakers yet, nor have I powered up the reversing camera, but it was sounding great.

The front speakers are just standard, not danny's yet as I wanted to get the rest working first before removing the virgin door cards.

so in essence, apart from the tweeters, all I have heard working is the sub powered by the PG. OMG how impressed am I.

No point saying more, other than I forgot just how good it was, and now with PG amplification it is that much better.
 

·
Registered
Joined
·
5,633 Posts
:smthumbup Dodgy/un-seated connection somewhere, either in panel at headunit or at amp...it happens.
(always keep an ipod and a 3.5mm jack to phono lead handy, helps eliminate the 'possibles' ;) ).

So, get you're finger out and get the rest of it installed:goingmad: i'd love to hear it with the PG - but can you imagine the cost of my sytem if i included PG's, i'd have never sold any:eek:, apart from to the old-skool purists like yourself:smthumbup

You wanna hear mine now ;) my 6channel amp weighs less than my Blackberry and draws < 4amps :angel: all speakers bonded into BIW.....still trying to work out a way of eliminating the MDF baffle (and carbon costs way to much to corrugate)....

connected up the amp finally today.

PG zx450. and.......NOTHING.

Can't figure it out, PG is showing power everything connected as it should be but no sound.

I went to bed totally frustrated and decided this morning to strip out the whole system and just run the DB front speakers off the head unit and some other kind of rear speakers.

This morning I refitted the headunit after taking it out to check the wiring and suddenly it works.

No explanation, nothing changed it just works.

Sadly I haven't connected the rear speakers yet, nor have I powered up the reversing camera, but it was sounding great.

The front speakers are just standard, not danny's yet as I wanted to get the rest working first before removing the virgin door cards.

so in essence, apart from the tweeters, all I have heard working is the sub powered by the PG. OMG how impressed am I.

No point saying more, other than I forgot just how good it was, and now with PG amplification it is that much better.
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #18 ·
how funny you say that.

Sitting next to me on my desk is the kjack to rca converter I rang ahead and asked my dad to fish out before I got to work.

I only reconnected the headunit so that the remote feed was working and hey presto it all worked.

Do you think the front speakers are going to make a marked improvement over the standard kenwoods then?

the bass is already damn impressive from the rear, I would have been happy with just that as an improvement to the sound set up.

I was condering fitting another small PG amp to run the sub, but have decided against it.

At £200 for the speaker set up, I think your system was already a bargain.

Its probably the only mod for the car that I could sell for what I paid for it and still have a queue of people asking to buy it.
 

·
Registered
Joined
·
5,633 Posts
I remember the day i bought my evo, i didn't think more bhp was needed - now look where i am!?!?!:lol:

What i mean to say is, if you like it now imagine what it 'could' be like with better components....bit of an impossible statement because we (humans) find it v.hard to imagine 'better' until we've experienced it - so 'yes' change the speakers.....if you only knew the origins of my drive-units you'd not ask :rolleyes:

The only thing with an additional amp for the sub would mean a mis-match between the rears and sub (as they are designed to function in tri-mode best to deliver the spectrum i desired/designed) - it can be done but you'd end up with a 'sweet-spot' in volume terms and thats normally only a source of customer complaint.

.....where did the kenwoods come from tho, they are not std? the std IX's are worse than the std VIII's. i've kept one of each to show others, def. a cost-down in the chassis and motor, naughty Mitsi:tsk:
 

·
Registered
Joined
·
4,227 Posts
Discussion Starter · #20 ·
it came with kenwoods front and rear, sold did my old 9 and my 8 before.

Both fronts and rears have a very much aftermarket looking wooden adapter.

You sure they have changed.

I think the fronts were coax and the rears were dual cone, although they might all have been dual cone.

I know what you mean about the trimode set up, thats why even though I had the sub working, I faded forward immediately as I wasn't sure what the tri mode crossover would do to the speaker outputs of the amp without the rear band pass speakers connected.

I really want to fit the fronts but the sound deadening I bought from you is now so old that it doesn't stick, and I don't want to open the doors up without being able to install something to deaden the rattles.

I think it's going to have to be ------ DYNAMAT!!!
 
1 - 20 of 87 Posts
Top