Lancer Register Forum banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
219 Posts
Discussion Starter · #1 ·
I've just fitted a cop kit to my 6, on idle everything is fine. Touch the accelerator and the engine light flickers on. I'm using yaris coils, made the loom myself and soldered everything. Coil packs fit well over the plugs. Any idea's what could be wrong?
 

·
Registered
Joined
·
755 Posts
hi just a idea refit the old coils and see if the problem goes away just to be sure you haven't disturbed some thing else , if it does then recheck all your wiring again :O)

.
 

·
Premium Member
Joined
·
1,062 Posts
What have you had to solder? When I did mine it was all just plug in to connectors, and had no issue with mine. What gauge wiring did you use??

I would check the above as suggested, then check all connectors on your COP and try again.
 

·
Profound thinker
Joined
·
6,343 Posts
Sad to hear you're having trouble, buddy.

Have you checked there isn't shorting anywhere beween the wires with a multimeter?

As said above - it might not be your loom. Old coils on to check that first.

Cheerz

Mark H
 
  • Like
Reactions: evo arms m7960

·
Premium Member
Joined
·
219 Posts
Discussion Starter · #5 ·
I used the same gauge as spoolinup were selling. I think it was 18awg. I soldered all of the crimped connectors. I don't understand why tick over is really smooth and when I give it some revs it shows up the engine light. I will refit the OEM coils and see what happens.
I did read somewhere you should stretch the spring in the coil pack,I'll try this too.
 

·
Premium Member
Joined
·
219 Posts
Discussion Starter · #7 ·
Not checked to see if any shorts. Not read the code either. Car is at my mothers so can't check until next week now. Thanks for the advice. Will update next Tuesday.
 

·
Premium Member
Joined
·
219 Posts
Discussion Starter · #8 ·
I've swapped to the original coils and the engine light is still flickering on. I've bridged pins 1 and 4 and the engine light and abs light are both flashing continuously. When I pull the pin engine light goes out and abs flashes 3 more times.
 
1 - 13 of 13 Posts
Top