Lancer Register Forum banner

1 - 9 of 9 Posts
G

·
Discussion Starter #1
A while back i reported that i thought my clutch might have been on its way out....sligyt slipping between 2nd and 3rd on boot down....
took her to castle combe not a problem at all....

forgot all about it....
the other day took her out for a blast again.
after about 25mins of boot ....same again?

took her out again a day or so ago for about 20mins...full on boot no problem...

feels like an automatic for a split second:( (maybe it is a charisma!http://www.lancerregister.com/graphics/laugh1.gif border|EQU| 0 align|EQU| absmiddle >)

i'm getting confused. any ideas?

Colie
 
G

·
Discussion Starter #2
yeah colie DRIVE SLOW AND DONT BOOT IT :D

hee hee lol hahaha woohooo yeah baby yeah :D sorry im not on drugs just bored:)
 
G

·
Discussion Starter #6
lol i think so mate :) pls come on tell me, im searching to get stuff soon for tuning so give me some advice them i will let u know how to take your car 0.60 3.5 secs honest
 
G

·
Discussion Starter #7
Moses

I'm the first person to like jokes, but you just turned Colie's thread into BS when he was asking for advice for his clutch problem.

Anyway, I suppose the intermittent nature of the problem points us to a driver fault. Indeed, I believe that many people have their left shoe (or in Paul's case HUGE BOOTS) resting on the clutch pedal without even realising it.
 
G

·
Discussion Starter #8
C,

must get me some of those racin' shoes the boys wear at track days!

they look remarkably like my TaeKwonDo training shoes!!!

I suppose if i my clutch does slip ... and i have to get out...of the car... i'll be able to give them a swift Ap Chagi without damaging my delicate little feet!;)

Colie
 
G

·
Discussion Starter #9
oh...i'm the hardest!......
.
.
.
.
.
.my Mrs told me;)..
sorry gotta go...got a manicure to do.....:)
 
1 - 9 of 9 Posts
Top