Lancer Register Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter · #1 ·
Purchased brand new Master and Slave cylinders from camskill and got them installed today by local mechanic and at first everything was kind of ok but after about 10 minutes of driving clutch is starting to stick again a bit, not bad at first but you can feel it is getting worse I think :( What else can I do or is there a reason why the new stuff hasn't worked??

Thanks.
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #3 ·
Hey Ian,

The pedal is sticking during. The sticking part isn't the main reason its so annoying, the main reason is that it looks as if the clutch isn't engaging fully when this happens :confused: I just went outside to move the car off the driveway and when I started it, sank the clutch, the twin plate rattling sound was very very low as if I didn't have the clutch fully engaged, it's supposed to be alot louder, as it was when I first got the car from the garage with the new cylinders. Also, now when coming off the clutch Ian I am getting a loud noise from the firewall, could it be the new slave cylinder??


Cheers
Leon
 

·
Premium Member
Joined
·
16,922 Posts
Yes :(..... i got too it before it did any real damage thankfully( block etc) , and now have new correctly sized Mitsu Bearings in ( Junked Yanky crap i put in at rebuild! ) and so far seems to be staying in spec...just!!, but crank is obviously worn so will walk again eventually...hopefully it will last the year as i wont be doing that many miles really...then i will pop crank back out and get it all redone, was planning to go through it all again over winter anyhows so not really a problem as long as it lasts till then... i will probably go with the NR bearing fix they have developed as well which sorts it once and for all....or maybe a stroker :D

Cheers
Ian
 

·
Registered
Joined
·
578 Posts
Another thing... the clutch pedal bracket, which holds the pedal to the firewall is made from very thin sheet metal. The bracket in my car cracked and basically fell apart causing the pedal to depress off-axis and stick intermitently. I had to remove the pedal and reweld gussets to the cracked bracket. That could be your problem as well.

Alex
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #10 ·
thanks Ian, I will check to see if all is well on the firewall end of things and also thanks Alex i will also check that! Another aspect of the problems just to give you mre details is that when switching gears and i sink the clutch i get this hard jerk from the car it also happens when disengaging as well :confused:
 
1 - 10 of 10 Posts
Top