Lancer Register Forum banner

1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
My Evo vi went in for its 1000mile service yesterday and to have the central locking made right underwarranty.

When I went to collect my pride and joy, the following I was told:
a) when installing the alarm, cables put through the bulkhead were stripped(needed replacing)#
b) this blew the ETACS control box (needs replacing) on order from Japan could be 6weeks
c) transportation blocks had not been removed from the car.

So why had every single box on the PDI sheet have a tick in it ( even the CL) does this mean that Mitsi simply drive them off the boat polish them up , tick some boxes and ship em out..I am most disapointed with this...what else could have been missed that could have caused me to crash and maybe die?

anyone else had any pre delivery problems.

great car though!
 
G

·
Discussion Starter · #2 ·
I've heard of this happening before (transportation blocks left in) but that was on a F**d (Xr3i :(). Seems pretty poor that Mitsi can't get ther act together. Still what do you expect from people from Bristol :).

Presumably being fixed under warranty?
 
G

·
Discussion Starter · #3 ·
chinka,
I expected something like that wud b the reason 4 non functioning CL.

The block thing is 1 of the most popular PDI mistakes.

Hope it gets sorted with the least possible agro.
 
G

·
Discussion Starter · #4 ·
Chinka

Are you still driving the car whilst awaiting parts? if so, make sure they have made the shorting electrical bits safe, else your pride and joy could be a charred black instead of 'orrible reims blue http://www.lancerregister.com/graphics/tonguewink1.gif border|EQU| 0 align|EQU| absmiddle >.

Who installed the alarm? Was it the dealer or an electrician?
 
G

·
Discussion Starter · #5 ·
it was mitsibushi, but not the dealer I collected it from...and yes it was wiring through the bulkhead that was stripped and has been replaced/fixed.
 
1 - 5 of 5 Posts
Top