Lancer Register Forum banner
1 - 20 of 30 Posts

·
Chief Nerf Herder
Joined
·
1,629 Posts
Discussion Starter · #1 · (Edited)
If I come off the accelerator sharply in the GT-A it sometimes stalls, which is a bit worrying as its meant to have anti-stall but I cannot find much detail on it.

I don't have to be on or coming off boost and it usually happens when I hit the brakes. For example, it does it when parking sometimes.

I have an AFR fitted and the only thing I have noticed is the gauge seems to show the engine blipping to lean and then straight round to mega mega rich for about a second then it corrects itself. I am pretty sure it is flooding.

I had though it might be the metal mr recirc valve but puzzled as to how it could be the cause when its not a 'coming off boost' issue.

Any help gratefully received as its starting to get on my wick.
 

·
Registered
Joined
·
1,844 Posts
This use to happen me, turned out to be a bad ground cable, the exact same thing will happen if you have a poor battery. :smthumbup
 

·
Registered
Joined
·
4,403 Posts
The first thing I would check would be the dump valve. A mates manual evo did the same thing a while back and it was the dump valve leaking. Not sure how they run in a GTA, but could be worth a look. Try reversing the DV and see if it still stalls, I assume you can do that with a GTA, but I'm not certain.
 

·
Registered
Joined
·
4,403 Posts
You reckon it could be the DV even off boost?
If it stalls coming up to traffic lights and stuff like that. I'd say it would be worth checking, even if just to rule it out. If you do a search on here for stalling you'll probably find that a majority / alot of the cases it's a leaking dump valve.
 

·
Registered
Joined
·
2,696 Posts
I've got a spare PLASTIC OEM dump valve off a 6 that is working OK - if you want to swop that onto yours to see if that eliminates the problem give us a PM with your telephone number.
 

·
Chief Nerf Herder
Joined
·
1,629 Posts
Discussion Starter · #9 ·
Cheers guys. Might take you up on that Tel if I cannot find my original plastic one. got an 8 MR on mine at minute. Gonna try n swap it over tomorrow.

:smthumbup
 

·
Registered
Joined
·
678 Posts
have you had the battery off or has the battery gone flat or anything with the battery changed recently? this use to happen with the 4 awhile back, turns out any changes or anything like that with the battery needs a ecu reset..

run the car for 5mins on idle, then turn all electrics on and air con and leave to run, then keep it all on and take for a steady drive! this sorted it on the 4
 

·
Chief Nerf Herder
Joined
·
1,629 Posts
Discussion Starter · #12 ·
have you had the battery off or has the battery gone flat or anything with the battery changed recently? this use to happen with the 4 awhile back, turns out any changes or anything like that with the battery needs a ecu reset..

run the car for 5mins on idle, then turn all electrics on and air con and leave to run, then keep it all on and take for a steady drive! this sorted it on the 4
Hmm - might be onto something there as I just realised the battery was disconnected just before this started happening :wallbang:

At the time I just assumed the ECU would relearn but maybe not. Gonna try that in morning :smthumbup
 

·
Chief Nerf Herder
Joined
·
1,629 Posts
Discussion Starter · #13 ·
So I did a reset and still seems to be the same. Beginning to wonder is my lambda sensor dying. sat idling at side of road after a drive and the AFR gauge was occasionally blipping to either really rich or really lean, but only for a split second then back to closed loop at around 146 -15.0.

Only other thing I noticed was when i did the idling with all lights etc on, I noticed the internal cabin light would go dim for a few secs then brighten up.

Confused now...
 

·
Chief Nerf Herder
Joined
·
1,629 Posts
Discussion Starter · #14 ·
Oops. Car stalled in middle of busy road today as I pulled up to turn right. Embarrassing :(

Gonna try the dump valve theory next...
 

·
Registered
Joined
·
228 Posts
Oops. Car stalled in middle of busy road today as I pulled up to turn right. Embarrassing :(

Gonna try the dump valve theory next...
Take the DV off and see if it is stuck partially open. When this happens you get the stalling as you describe. When you give the car a little throttle, as in parking, and then suddenly shut the throttle, the excess intake air after the turbo will leak back into the intake pipe and possibly back out the MAF the wrong way, obviously confusing the ECU.
 

·
Registered
Joined
·
78 Posts
Mine did same when got my car when came off throttle quick, bov was pulling in air after afm which messed up fuelling.... fitted forge recirc valve and now spot on :smthumbup
 

·
Chief Nerf Herder
Joined
·
1,629 Posts
Discussion Starter · #20 · (Edited)
did you find you're dump valve Baby - if not I could drop mine to you on sat ??
Found it Terry but thanks for offer :smthumbup

I am going to try the dump valve today tomorrow as that's got to be it since it was changed to an 8 MR recirc valve. not having a lot of luck with spares for Evo at minute...
 
1 - 20 of 30 Posts
Top