Lancer Register Forum banner

1 - 9 of 9 Posts
G

·
Discussion Starter · #1 ·
Ive lost my SSSSPPPPPPPPPpppppppppssssssssss from my HKS SQV, just suddenly stopped. All I can hear now is my blades stalling. All the pipes are still connected and nothing was changed before it occured. One thing I have noticed is that it wont boost as easily as it did.
Anyone have any ideas, must not like the cold weather.
Cheers
Al
 
G

·
Discussion Starter · #2 ·
Al,
Has the vacuum tube become detached , that is the small tube from intake manifold 2 the SSQV.
 
G

·
Discussion Starter · #3 ·
Dont think so, I had a quick look today and couldnt see anything, will have a better look when I get home. I can see why you put your car in storage. Passing a gritter at 50 mph is not good, especially when it sits in the middle lane.
Cheers
Al
 
G

·
Discussion Starter · #4 ·
Good grief , I'd need sedation and post traumatic shock therapy if my Evo was subjected 2 that !
 
G

·
Discussion Starter · #6 ·
Have no filter, but will check that none of them have split. Also see if they have come clogged.

Evoboy,
I know I found loads of salt in my engine bay. I think the gritter bloke was taking the #### by being in the middle lane. Must be another way of getting the salt down, I know its a saftey issue, but how safe it firing grit at a car on the motorway.
 
G

·
Discussion Starter · #7 ·
Al,
Just had a worrying thought , the SSQV isn't full of salt is it ?
Like u , drove past a gritter doing the centre lane thing last night in my shed , salt going everywhere , did I care , no I didn't :)
 
G

·
Discussion Starter · #8 ·
Checked that the pipes were not blocked last night, will take the SSQV of tonight and clean it out.
Dont blame you for not caring about your shed, bet you would have waited on the hard shoulder until the gritter went of at the next junction if you were in the Evo:). I would have.
 
G

·
Discussion Starter · #9 ·
Found out the problem, basically its kanckered, for some reason something came lose in the housing in which the valve is situlated. This meant that the diagrham couldnt move and so no air escaped. So tried to take it apart but couldnt. Ended up moving the thing around until the screw on the back went in and there was nothing movng around. Put it back in and were back in working order. Hopefully for good.
 
1 - 9 of 9 Posts
Top