Lancer Register Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1
Been moaning about a surging feeling under full throttle accels. especially in 3rd gear. Fitted a boost gauge today and went out for a driveability assessment ;)
The boost control as I suspected and has been stated by other owners is rubbish. In 3rd the gauge rose to 19psi before dropping to 15 and then rising back to 19 by about 5500-6000rpm.

You can really feel this boost fluctuation behind the wheel.

Any simple cures or is the ECU just not capable of good control?

Jason :)
 

·
Registered
Joined
·
217 Posts
have the same problem of surge in mine- especially in third. I was under the impression it was down to the restrictive exhaust. I quite like it though, just wish it didnt stop then come back again
 

·
Registered
Joined
·
10,911 Posts
i think we should all sell the 260's and buy the real deal.......

only a thought

or have the mofo tuned!!
 

·
Registered
Joined
·
347 Posts
the kid said:
i think we should all sell the 260's and buy the real deal.......

only a thought

or have the mofo tuned!!
Naaaaah, boost controller sounds easier, but what exactly do they do ? And how easy are they to fit.....?
 

·
Registered
Joined
·
1,839 Posts
gripper said:
Naaaaah, boost controller sounds easier, but what exactly do they do ? And how easy are they to fit.....?
PM lee5 mate he is the daddy with that sort of thing :coolsm:
 

·
Registered
Joined
·
81 Posts
Yip I was the first to report this problem :(

I tried an AVCR back then to see if the problem was mechanical or electronic and it solved the problem.

The problem is in the standard ecu software.
The maximum wastegate duty cycles are set too high standard.

If you want to keep your warranty, an Ecutek re-map will solve the problem and is undetectable by the agents. Just costs $$.

Perhaps the agents will solve it for you??

rupert
 

·
Registered
Joined
·
307 Posts
Discussion Starter #10
I plan to fit a mechanical boost controller I used on my previous evo at the weekend to see if this solves the problem, Just for my own knowledge.
Car is due for a service next month so I'll ask the dealer to look into it.

Jason :)
 

·
Registered
Joined
·
307 Posts
Discussion Starter #11
Boost tests

Finished early today so deicded to fit my manual boost controller.
Could not fit it exactly as I had on my E5 as I couldn't remove the turbo inlet pipe :mad: needed to get at the jubile clip from under the car but did not find this out until I had most of the pipe work off. So I just fitted it in place of the solenoid valve.
Just got back from testing, boost is now stable all the way through the rev range, getting 14psi on my gauge, I believe this to be the wastegate actuator spring strength?, could not seem to increase this with my boost controller but I think I have found out the reason for this.

Anyone tell me what the std boost setting should be so I can set to that tomorrow?

Jason :)
 
1 - 12 of 12 Posts
Top