Lancer Register Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,451 Posts
Discussion Starter #1
Just as it's about to go to the dealer this happens :mad:
Apart from paying the stupid price's for this from Mitsi what are my alternative's :confused:
Cheers
Fra :D
 

·
Registered
Joined
·
1,451 Posts
Discussion Starter #3
Yes,but seemingly it might need a new pump :confused:

Scenario is this,car is being taken off my hand's from Mitsi dealer but i lose £1000 if the car actually need's the pump and time is of the esscence here :mad: :blah:
 

·
Registered
Joined
·
235 Posts
Ok.... normal cause of failure is the presure switch.

Have you had Mitsubishi read the error code to see exactly what it's complaining about?

Presuming it is the switch, then drop an email to RogerRally on here as he should be able to sort you out with a new switch that'll sort that out. Oh... and the switch is £120 and takes 20 minutes to fit. Beats the grand Mitsubishi want then!!
 

·
Premium Member
Joined
·
14,884 Posts
Might just be the pressure switch. Mitsi sell you the complete pump because the switch cannot be bought on its own :rolleyes:

If it is the pump you should be able to pick one up second hand for a fraction of the cost.
 

·
Registered
Joined
·
1,451 Posts
Discussion Starter #6
That will probably be it...the pressure switch i mean.Will find out later today :rolleyes:

Oh the f*ckin joy's :blah: :cry: :mad:
 

·
Premium Member
Joined
·
14,884 Posts
grale22 said:
From what I remember, fault code 82 is the one for presure switch failure.
Yes, fault code 82 & 83 can indicate a defective accumulator pressure switch.
 
1 - 10 of 10 Posts
Top