Lancer Register Forum banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
173 Posts
Discussion Starter · #1 ·
right guys i fixed my previous issue with an after market boost controller but now, when my car is started its fine and normal then after a few minutes of running a whining noise (not my missus) starts from the back electrical whine the consistency is stable of the noise but if i was to for instance flick the window switch up the noise level and tone will fluctuate, the noise is coming from fuel pump im almost certain of it (not the speakers as its all switched off) ayc pump is removed so wont be that either.

when im hitting boost my car will cut and go bang like i hit the limiter, is this the fuel pump gone bad?
 

·
Premium Member
Joined
·
22,093 Posts
sounds to me like you still have a boost issue, either too much, or a leak somewhere. Aftermarket fuel pumps tend to be noisier, and you can hear them if you listen for them. If you feel the pump maybe knackered, its probably best to get your fueling checked, or for what they cost, replace the pump. But there is no link between fuel supply and boost / fuel cut, that is determined by air flow over the MAF, or air pressure if you've converted to MAP

Stu
 

·
Premium Member
Joined
·
173 Posts
Discussion Starter · #3 ·
am running 1.6 bar and was running this amount without any issues for over a month since i had my previous issue fixed, also running 2 bar peak when i really want to boost hard lol again was fine for a month. also im not smoking at idle or boost.

when i say my fuel pump is whining i mean its loud as hell, like loud loud not normal. it always starts quiet and gradually gets loud as the car is left running
 

·
Premium Member
Joined
·
22,093 Posts
am running 1.6 bar and was running this amount without any issues for over a month since i had my previous issue fixed, also running 2 bar peak when i really want to boost hard lol again was fine for a month. also im not smoking at idle or boost.

when i say my fuel pump is whining i mean its loud as hell, like loud loud not normal. it always starts quiet and gradually gets loud as the car is left running
well id be changing the pump asap, definitely not boost till its done, wont take long with fuel shortage to kill the engine, if it is failing

As for boost, its not the pressure you see on your boost guage that causes the cut, its the measured air over the maf, so a boost leak is wasted air, but measured air, increases air over the maf = cut

What model evo (and what engine if not original) is this? Has the car been mapped for 2 bar? Thats more than people usually run. I wasnt far off that on my 5, peaking at 1.95, but it was mapped and fueling checked for it, my risk with the engine

Stu
 

·
Premium Member
Joined
·
22,093 Posts
its an evo 8 fq300, isnt mapped just increased boost via an electronic controller.
1.6 bar is risking killing it, 2bar is begging for the engine to blow without mapping

The unmapped ecu wont allow that boost( not even 1.6), i'd guess it has been remapped at some time in its life if you have managed 2 bar, but that is crazy boost to run without a map, or at very least getting the fueling checked

Stu
 

·
Premium Member
Joined
·
173 Posts
Discussion Starter · #9 ·
1.6 bar is risking killing it, 2bar is begging for the engine to blow without mapping

The unmapped ecu wont allow that boost( not even 1.6), i'd guess it has been remapped at some time in its life if you have managed 2 bar, but that is crazy boost to run without a map, or at very least getting the fueling checked

Stu
I by-passed the standard solenoid so guessing the ecu isnt detecting the boost increase, im just curious why the car was running fine for avwhile with my current setup but all of a sudden the fuel pump started crying and exhaust is popping when i hit high boost, ill crank it down tomorrow and see what happens. Will get a remap once i have time off from work.
 

·
Premium Member
Joined
·
22,093 Posts
I by-passed the standard solenoid so guessing the ecu isnt detecting the boost increase, im just curious why the car was running fine for avwhile with my current setup but all of a sudden the fuel pump started crying and exhaust is popping when i hit high boost, ill crank it down tomorrow and see what happens. Will get a remap once i have time off from work.
the ecu will see the higher boost, as i say, its read by the MAF. Id turn it down to 1.3 bar or less until you are ready to get it remapped, and if you feel the pump is failing, replace that before the remap too

Stu
 
1 - 10 of 10 Posts
Top