Lancer Register Forum banner
1 - 20 of 50 Posts

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #1 · (Edited)
Not entirely sure where to start, but in short I had a long rod drop in rebuild done in 2010, I ran this with an Evo 9 turbo at 420/425 this was fine for 8k miles until last year just before the mlr spa track day when it started to smoke :( did the trip anyway and apart from a cracked water pump pulley all was ok.
Once back in the uk had a leak down test done and found out cylinder 1 was loosing 12% :(

Time for an unexpected rebuild

All parts sourced from Ross sport



Engine out with help from b6lee and others








 

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #2 · (Edited)



Engine ready to go back in with all the normal upgrades including a new clutch and flywheel

While the engine was out attention was turned to my Evo 9 turbo that was rebuilt with a BB core when I originally bought it but was now in a bad way due to oil starvation :(

Sourced an s205 and all ready to put back in the car





I had sent a standard exhaust manifold off to be ported but it wasn't ready to go back in with the engine :(
Ran the engine in on a basic map then it was time to go to madevelopments for a full map, with still no sign of the stock manifold I ordered a ctec one :)



Work of art :)

 

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #3 · (Edited)
The car was mapped and made 466 bhp 405 Lb/ft @ 1.8 bar which I was happy with but still needed to get my cams dialed in

With 1k miles of driving after running the engine in the s205 developed some play :( always a problem buying 2nd hand parts you never know how long they will last

This left me with another unexpected decision to make, what turbo to try next :)

I have ended up with a Ross sport kit with a gt3076 turbo




I also decided I should make a list of other things to do while it's off the road and also a little impulse buying

First up brakes

Got a set of 2nd hand k-sports which looked a little tired so they where sent to Godspeed for a freshen up






These have been fitted with some xp10's curtesy of thetyrant

The standard rear Brembo's were feeling a little left out and where also yellow, so these got the Godspeed treatment also



And are now waiting to be fitted
 

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #5 ·
Quick update, turbo fitted :)




Now need to move my breather catch can as it's in the way of the filter, so while I'm at it am going to change the -10 fittings to black ones :)
 

·
Premium Member
Joined
·
751 Posts
Wow, great Mods! Best of luck! I'm sure she'll be sounding like a beast in no time!
 
  • Like
Reactions: simplefound

·
Premium Member
Joined
·
5,632 Posts
sorry to hear the 205 went bro... gutted for you....

the red blew up just before yours did.... so was in the same dillemma

settled for a gtx 3076 :)

hows she running now?
 
  • Like
Reactions: Gtiandy

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #10 ·
Did you get o the bottom of what caused the problem on the original long rod build??
It appears cylinder 1 was worn unevenly and as I had drop ins they were measured but it may have been missed :( it was ok at first as the new rings took up the gap but they must have move round opening up to cause a problem, just one of those things.
 

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #11 ·
sorry to hear the 205 went bro... gutted for you....

the red blew up just before yours did.... so was in the same dillemma

settled for a gtx 3076 :)

hows she running now?
Yeah gutted but turbos don't live forever, shame about the red but they are made of chocolate :) (please don't shoot)

Not running yet still need to go see Ross for a slim fan, down pipe, lower intercooler pipe and some other little bits

Loads of other things I still want to get done before it's running but planning for end of feb and have my name down for the RR day at Hayes in March :)

How's yours running with the gtx?
 

·
Premium Member
Joined
·
10,865 Posts
It appears cylinder 1 was worn unevenly and as I had drop ins they were measured but it may have been missed :( it was ok at first as the new rings took up the gap but they must have move round opening up to cause a problem, just one of those things.
Sorry to hear that mate :smthumbdo

As you say one of those things, that's the perils of drop ins.

Well you have a monster build now so its all worth it!!
 

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #14 ·
Sorry to hear that mate :smthumbdo

As you say one of those things, that's the perils of drop ins.

Well you have a monster build now so its all worth it!!
Yeah all worth it in the end :)

Someone said to me "do it right, do it once" which is how I am now looking at things. Costs a bit more to start with but less in the long run :)
 

·
Premium Member
Joined
·
10,865 Posts
Yeah all worth it in the end :)

Someone said to me "do it right, do it once" which is how I am now looking at things. Costs a bit more to start with but less in the long run :)
Totally agree fella, I always overspec on everything, costs a bit more to start but worth it in the end :)
 

·
Premium Member
Joined
·
654 Posts
Discussion Starter · #16 ·
A few more bits have now been done

Got round to making a bracket for my breather and got some new black pipe and fittings (still need to do one pipe)





I also got a 2nd hand koyo from a guy on here for a good price so have fitted that, not sure what others have done but on the standard rubbers in the brackets it sits to close to my turbo so have had some bushes machined to hold the rad forward





 

·
Premium Member
Joined
·
5,868 Posts
oh how the first part of this story brings back memories, great thread si :smthumbup
 
1 - 20 of 50 Posts
Top