Lancer Register Forum banner
1 - 20 of 27 Posts

· Premium Member
Joined
·
518 Posts
Slightly off topic but do they all make a ticking noise on part throttle or is it just my greedy one that does? I know you should mount them down nearer the front of the engine bay on a rubber gasket but still noisy?
 

· Premium Member
Joined
·
2,222 Posts
Slightly off topic but do they all make a ticking noise on part throttle or is it just my greedy one that does? I know you should mount them down nearer the front of the engine bay on a rubber gasket but still noisy?
Yes, they all make a noise. I've mounted mine on a small bracket next to the slave cylinder using one its bolts- I can barely hear it now. If it's bolted to the chassis/ body then you will be far more likely to hear it :smthumbup
 

· Premium Member
Joined
·
1,737 Posts
Just following up on this, haven't bought the solenoid yet.

Checked on the Autotorque site but could't find it so now looking at this MAC solenoid with electric controller.

Anyone tell me if this is worth it or would the solenoid on it's own be enough?

Thanks.
We don't have an online store yet

If you call I can get one out today for you :)
 

· Premium Member
Joined
·
4,338 Posts
I'm on my second Mac 3 port, the first one failed when the car was laid up, and wouldn't make boost when I started using it again.......the second one's been on for 5 years with no issues so far.

When first fitted, mine was touching the chassis, it sounded like the crank was toast! Isolated it, again, fine now.
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top