Lancer Register Forum banner
rough idle
1-5 of 5 Results
  1. Technical Questions
    I bought an evo 5 gsr recently and it would idle very inconsistently to the point it would almost stall and then jump high, so I bought a new idle control valve as the one that was on there looked like it was bodged. Iā€™ve had it on there for a few days and probably driven it about 80 miles in...
  2. Technical Questions
    Right so I've had a rough idle and a loss of power on acceleration from standstill for a couple of weeks now and Its driving me crazy. I had two fault codes P0202 and P0350 which I have looked up something to do with ignition coils. I've replaced all the ignition coils and the spark plugs. I've...
  3. Engine / Turbo
    having searched the forum it would appear misfiring is a common issue for the Evo. I just wanted to through my experience into the hat and see if others agree? I was joining a dual carriageway and as i started to press down on the go go button there was a sudden and noticeable drop in power...
  4. Technical Questions
    Dear Members, this is my first thread since I just got my 2010 Evo X 360. Before collecting the car I fitted a Blitz BOV and a de-cat. I picked up the car and drove for 15 miles or so and the car warning light came on saying 'Service Required' and the car just lost power. When pulled over, the...
  5. Technical Questions
    Dear Members, this is my first thread since I just got my 2010 Evo X 360. Before collecting the car I fitted a Blitz BOV and a de-cat. I picked up the car and drove for 15 miles or so and the car warning light came on saying 'Service Required' and the car just lost power. When pulled over, the...
1-5 of 5 Results
Top