Lancer Register Forum banner

misfire

  1. Technical Questions
    Hi all, I have an evo 5 which has a misfire under load in 3rd,4th and 5th gear. I’ve spent the last few days reading posts in the forum and the general consensus is to replace plugs, (gap them correctly) and if still not resolved then replace coil packs. I’ve been using the bpr8es plugs for...
  2. Technical Questions
    My evo 6 has a terrible misfire around 3500-4000 rpm. I tought it could be the coils so I’ve put in a Spoolinup COP kit. It didn’t fix the problem. The problem occured right after I fueled at an unknown petrol station. Could this be due to bad fuel? I’m running non gapped BPR8ES spark plugs...
  3. Engine / Turbo
    stalling at idle (fixed) - Misfiring on Boost My Evo 8 started to misfire as the boost comes on around 3k RPM in any gear, recently had a service done inc the plugs so swapped the plugs for another set still had the same issue. Thought was one of the coil leads as it only effect on cylinder...
  4. Engine / Turbo
    having searched the forum it would appear misfiring is a common issue for the Evo. I just wanted to through my experience into the hat and see if others agree? I was joining a dual carriageway and as i started to press down on the go go button there was a sudden and noticeable drop in power...
  5. Technical Questions
    Whats up guys, Just got my evo 8 like a week ago. Car runs fine the only problem is it wont pull after 4500-5000 rpms! It builds boost at 3000 and stops pulling at 5000. I'm running stock Boost. Not sure what could be causing. My guesses are 1.Boost Leak...maybe 2.Bad MAF Sensor...maybe...
  6. Technical Questions
    Car parked for 3 years, full ralliart services, driving perfectly before parked up, fuel line leak never got round to fix. Took to ralliart on trailer (not started), 72k service done, new brake lines, corroded fuel lines from tank to rear door area renewed with aeroquip, new filler neck (fuel...
Top