Evo 5 main beam not working - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Electrical / Security / ICE / Navigation

Reply
 
Thread Tools Rate Thread Display Modes
Old 20-08-2019, 07:59   #1
JonW
Registered User
 
Join Date: May 2018
Posts: 22
Evo 5 main beam not working

Hi, It seems my main (low) beam isnt working. The high beam and the side lights work fine.

Anyone got any ideas on something to check other than the relays and fuses as I looked at the fuse/relay pod on the wing in the engine bay and everything looks ok in there.

Any help greatly received before I start pulling out meters and working through the system... Any wiring diagrams would be good for that too ta.

I did originally have an issue with this and wobbling the connector on the drivers side headlight bulb did bring them back to life, but that bodge isnt working now. Perhaps there is a connection issue in there? or am I grasping at straws lol.
JonW is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 20-08-2019, 08:06   #2
plip1953
Phil
 
plip1953's Avatar
 
Join Date: Feb 2008
Location: West Yorkshire
Car: Evo X RS
My Car
Posts: 10,621
Maybe try changing the bulb?
__________________
Phil
plip1953 is offline   Reply With Quote
Old 20-08-2019, 10:45   #3
JonW
Registered User
 
Join Date: May 2018
Posts: 22
Haha, yep, Ive done that... tried 2 just to make sure lol

I was wondering if there was some fuse or relay i was missing in my search or there was a common Evo 4/5/6 issue with say the stalk switch or some connector etc. I did google that sort of issue but came up empty so figured it was worth asking here.

Last edited by JonW; 20-08-2019 at 10:47..
JonW is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 20-08-2019, 21:03   #4
Uzumaki
User
 
Uzumaki's Avatar
 
Join Date: Jul 2011
Location: AUSTRALIA
Car: JDM TME & Evo Wagon & Evo 8MR Ralliart Edition in pieces
My Car
Posts: 54
Stalk switch.
I had the same issue on my V and VI.
It switches earth between low beam and high beam. (when it's working)
MR277093 SWITCH,TURN SIGNAL LAMP & LIGHTING
__________________
IG: @uzumaki.garage
Uzumaki is offline   Reply With Quote
Old 21-08-2019, 21:33   #5
JonW
Registered User
 
Join Date: May 2018
Posts: 22
Ah ha! There it is, I did wonder. Thanks so much Uzumaki, I'll get one bought!
JonW is offline   Reply With Quote
Old 13-09-2019, 01:59   #6
JonW
Registered User
 
Join Date: May 2018
Posts: 22
Update: New MR277093 stalk switch fitted and I now have main/low beam again. Perfect. Thanks Usumaki!

If anyone else in Aus is looking for one of these, dont bother with the dealer (I know we already knew this!) they wanted $568 for this switch. Amayama supplied one for a much more sensible $123. I cant quite believe Mitsubishi Aus's gall really, this is a Lancer part and considering most normal Lancers are circa $2k ****ters with short rego this would be >1/4 the value of the car. I know if they needed a clutch it'd be the same fitted but this fault would see some people scrap those cars... food for thought.

My advice to anyone with a 4/5/6/6.5 you want to keep is to get one of these and store it safely as it fails without provocation. My car is very low mileage but still this thing died.
JonW is offline   Reply With Quote
Old 13-09-2019, 06:52   #7
adamlstr
Senior User
 
adamlstr's Avatar
 
Join Date: Nov 2003
Location: Bucks
Car: VI GSR, Scotia
My Car
Posts: 667
On a similar line, do you think there's a way to get both low and high beam to light up when you select high beam? If you hold the stalk back when you switch to high, they both stay on and emit much more light.

Anything to get brighter lights would be good.
adamlstr is offline   Reply With Quote
Old 15-09-2019, 00:53   #8
JonW
Registered User
 
Join Date: May 2018
Posts: 22
Adam, the way I read what is written above is that you cant have em both on at the same time as the switch swaps the earth between the 2 functions can you? Or are you saying that youve tried this?

Quote:
Originally Posted by Uzumaki View Post
It switches earth between low beam and high beam. (when it's working)
I guess the problem is that while you get more 'light' its not really where you need it. i.e. if you want more low beam then the high beam is not at the right angle/area and vice versa.

I agree better lights would be very nice indeed. I cant believe the speeds I used to drive country lanes at nights with only candles like these back in the day

What I did fit on my WRX back then was fit the same PIAA light units I now have on the V, but they were the driving light version. These really lit up the road on high beam like it was day (the set I had came from an RB5 which had them as standard instead of fogs). I've been tempted to grab a set of new lenses for my PIAAs and run them as driving lights, but my car is bone stock and low milage so its not desirable to mod it really plus it's a bit of effort to create a loom with relays/switch etc. ...and I live in the city now so rarely drive in pitch black or away from oncoming cars... :/

Last edited by JonW; 15-09-2019 at 01:01..
JonW is offline   Reply With Quote
Old 04-10-2019, 17:00   #9
kawkaty
Registered User
 
Join Date: Oct 2019
Posts: 12
Quote:
Originally Posted by JonW View Post
Adam, the way I read what is written above is that you cant have em both on at the same time as the switch swaps the earth between the 2 functions can you? Or are you saying that youve tried this?



I guess the problem is that while you get more jiofi.local.html tplinklogin 'light' its not really where you need it. i.e. if you want more low beam then the high beam is not at the right angle/area and vice versa.

I agree better lights would be very nice indeed. I cant believe the speeds I used to drive country lanes at nights with only candles like these back in the day

What I did fit on my WRX back then was fit the same PIAA light units I now have on the V, but they were the driving light version. These really lit up the road on high beam like it was day (the set I had came from an RB5 which had them as standard instead of fogs). I've been tempted to grab a set of new lenses for my PIAAs and run them as driving lights, but my car is bone stock and low milage so its not desirable to mod it really plus it's a bit of effort to create a loom with relays/switch etc. ...and I live in the city now so rarely drive in pitch black or away from oncoming cars... :/
I did originally have an issue with this and wobbling the connector on the drivers side headlight bulb did bring them back to life, but that bodge isnt working now. Perhaps there is a connection issue in there? or am I grasping at straws lol.

Last edited by kawkaty; 05-10-2019 at 00:13..
kawkaty is offline   Reply With Quote
Old 04-10-2019, 17:03   #10
kawkaty
Registered User
 
Join Date: Oct 2019
Posts: 12
Quote:
Originally Posted by JonW View Post
Update: New MR277093 stalk switch fitted and I now have main/low beam again. Perfect. Thanks Usumaki!

If anyone else in Aus is looking for one of these, dont bother with the dealer (I know we already knew this!) they wanted $568 for this switch. Amayama supplied one for a much more sensible $123. I cant quite believe Mitsubishi Aus's gall really, this is a Lancer part and considering most normal Lancers are circa $2k ****ters with short rego this would be >1/4 the value of the car. I know if they needed a clutch it'd be the same fitted but this fault would see some people scrap those cars... food for thought.

My advice to anyone with a 4/5/6/6.5 you want to keep is to get one of these and store it safely as it fails without provocation. My car is very low mileage but still this thing died.
Any help greatly received before I start pulling out meters and working through the system... Any wiring diagrams would be good for that too ta.
kawkaty is offline   Reply With Quote
Old 04-10-2019, 17:23   #11
jhfozzy
S.Wales R.O./Electrician
 
jhfozzy's Avatar
 
Join Date: Apr 2007
Location: Swansea
Car: Evo VI
My Car
Posts: 4,076
Quote:
Originally Posted by kawkaty View Post
Any help greatly received before I start pulling out meters and working through the system... Any wiring diagrams would be good for that too ta.
All the wiring diagrams are available on the homepage.

Best thing is to work logically through the circuit, I'd start at the lamp terminal to see if you have power there.
__________________
John
jhfozzy is offline   Reply With Quote
Old 04-10-2019, 17:29   #12
grants
Senior User
 
grants's Avatar
 
Join Date: Sep 2003
My Car
Posts: 9,052
Troll alert
grants is offline   Reply With Quote
Old 05-10-2019, 22:58   #13
JonW
Registered User
 
Join Date: May 2018
Posts: 22
Kawkaty, I has exactly the same issue and it was fixed with a new switch. They are not expensive from Amayama etc. Cheaper than a day of your time etc
JonW is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 21:34.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.