Intermittent Engine Light - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Technical Questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-07-2019, 18:20   #1
DannyJ
Senior User
 
Join Date: Jan 2016
Location: Suffolk
Car: Evo 8 MR FQ340
Posts: 149
Intermittent Engine Light

I've got an 8 FQ340 mapped to 380 by the guys at APT. Just over a month ago I finally got the AC working and started getting some idling issues. Essentially it would cold start fine but if I restarted it the thing would damn near stall unless I had my foot on the throttle.

Guys at APT suggested looking at the throttle body which I've now had off and cleaned - it was in a terrible state. I also took the opportunity to clean up the ICV a bit. After refitting everything the idling issues are gone and I dare say it seems to be running great .

So onto the new problem (it never bloody ends ). While driving along the engine light came on but after a few seconds it cleared. After messing around a bit it seems the light is coming on if I'm around 3500rpm, hit the throttle and then quickly let off, like I'm hesitating. It also happened when I put my foot down in too high a gear (I wasn't paying attention) but cleared once I shifted down.

Any ideas on where I need to look next? I'm still very much a noob at figuring these issues out. I'm hoping to do a boost check on Friday once I can get my hands on something to hook my compressor up to the intake but I would have expected the car to be running a bit rough if it was something like that.
DannyJ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 16-07-2019, 18:42   #2
tracker
Senior User
 
Join Date: May 2011
My Car
Posts: 2,277
Have you checked for any stored fault codes
tracker is offline   Reply With Quote
Old 16-07-2019, 19:40   #3
DannyJ
Senior User
 
Join Date: Jan 2016
Location: Suffolk
Car: Evo 8 MR FQ340
Posts: 149
You see this is the kind of sensible ideas that I've yet to master. Because the light went off I didn't think to check for codes .

I got 3 codes, P0100, P0105, and P0110. A quick search says these all seem to be related to the MAF so could it be that going out? Are there any cheaper things I can test since the car mostly seems to be running ok?
DannyJ is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 16-07-2019, 22:21   #4
kikiturbo
Senior User
 
Join Date: Feb 2008
Location: Croatia
Car: EVO 9 GSR
My Car
Posts: 2,752
is the light on continuously or blinking?
kikiturbo is offline   Reply With Quote
The Following User Says Thank You to kikiturbo For This Useful Post:
Rampant (17-07-2019)
Old 17-07-2019, 05:21   #5
Rampant
Profound thinker
 
Rampant's Avatar
 
Join Date: Oct 2005
Location: Orbit pattern - Low block 3
Car: Evo VI GSR Import (& F80 M3 Comp & 997 Turbo)
My Car
Posts: 6,262
Quote:
Originally Posted by kikiturbo View Post
is the light on continuously or blinking?
I'm thinking along the same lines.

What this might be is the ECU remap using a feature that flashes the CEL when the engine knock sensor detects knock.

From the fault description above, this would be consistent with the remap having a bit too much ignition advance and the knock sensor detecting detonation - particularly if you're getting CEL flashing at a very consistent rpm during wide open throttle pulls AND also when on wide open throttle in higher gears.

With the hot weather recently, this might be the cause of the remap was in winter cold weather...

If it is a transient and regular flashing of the CEL, if it were me I'd avoid the driving regimes that trigger the flashing light and get it back to whoever did the remap ASAFP.

All the best

Mark H
__________________
Je cherche l'orgasme d'auto
J'ai trouve l'orgasme d'auto
C'est une evo VI bleu par le Rountree

***Go soothingly on the grease mud, as there lurks the skid demon***
//// Do as you OUGHT, not as you WANT ////
Rampant is offline   Reply With Quote
The Following User Says Thank You to Rampant For This Useful Post:
DannyJ (17-07-2019)
Old 17-07-2019, 08:26   #6
DannyJ
Senior User
 
Join Date: Jan 2016
Location: Suffolk
Car: Evo 8 MR FQ340
Posts: 149
Thanks for the replies. When it comes on it stays on and then if I put my foot down in an appropriate gear or just drive sensibly it switches off after a few second. Guess I'll be taking a trip to Norwich in the near future.
DannyJ is offline   Reply With Quote
The Following User Says Thank You to DannyJ For This Useful Post:
Rampant (17-07-2019)
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 03:43.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.