Work log - Kenneth's EVO VI TME - Page 4 - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > General Stuff > Projects & Restorations

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-05-2019, 12:38   #46
madspeed
Senior User
 
Join Date: Oct 2011
Posts: 111
Quote:
Originally Posted by Kenneth- View Post
I need some advice!

My left front wheel (my drivers side) is 10 mm further back, than the left.
1. It looks stupid.
2. It rubs when turning.
3. It was like this before coilovers as well.

I've had the car up in the air for 10 minutes, and it looked good - no damages or dents whatsoever. So it looks fine, and the bushings are tight.

Help?
Subframe or control arm accident/damage possibly.
madspeed is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 14-05-2019, 05:26   #47
war-machine
Senior User
 
war-machine's Avatar
 
Join Date: Dec 2015
Location: uxbridge
Car: evo 7 rs
Posts: 1,260
check bush’s in steering rack...they have 3....also check inner tie rod for wear or damage...get a pry bar and have a good look


Sent from my iPhone using Tapatalk
war-machine is offline   Reply With Quote
Old 14-05-2019, 05:31   #48
war-machine
Senior User
 
war-machine's Avatar
 
Join Date: Dec 2015
Location: uxbridge
Car: evo 7 rs
Posts: 1,260
Quote:
Originally Posted by madspeed View Post
Subframe or control arm accident/damage possibly.


check inner tie rod legth...its in manual somewhere...tie rod may have started to move anti Clockwise because locking tab washer missing or come loose...never seen one come undone before...pretty easy to change or new locking tab...just a guess


Sent from my iPhone using Tapatalk
war-machine is offline   Reply With Quote
Old 14-05-2019, 05:32   #49
war-machine
Senior User
 
war-machine's Avatar
 
Join Date: Dec 2015
Location: uxbridge
Car: evo 7 rs
Posts: 1,260
Quote:
Originally Posted by war-machine View Post
check bush’s in steering rack...they have 3....also check inner tie rod for wear or damage...get a pry bar and have a good poke


Sent from my iPhone using Tapatalk





Sent from my iPhone using Tapatalk
war-machine is offline   Reply With Quote
Old 14-05-2019, 10:37   #50
Kenneth-
Registered User
 
Kenneth-'s Avatar
 
Join Date: Aug 2018
My Car
Posts: 47
Thanks guys. I'll get it in the air again and have a proper look and poke.
Kenneth- is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 23:58.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.