JDM Evo 7 AYC pump causing voltage drop/oscillation. Please Help! - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Technical Questions

 
 
Thread Tools Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 24-03-2020, 23:51   #1
adriank
Registered User
 
Join Date: Mar 2020
Posts: 3
Question JDM Evo 7 AYC pump causing voltage drop/oscillation. Please Help!

Hey guys,

I've been trying to figure this out for some time now, my AYC pump causes a large voltage oscillation when its pumping. (it always pumps after 50% throttle or so and turns on even in straight line) The voltage oscillation causes my dash lights to flicker/dim and my AFR goes up and down because the injectors areing seeing linear voltage at WOT. There have been a few others with the same problem on here but it never came to a conclusion. Another thing i noticed is when i have the engine off and ignition on and i step on the throttle, the AYC pump keeps pumping and never shuts off. Here is a thread with the same electrical problem.

https://www.lancerregister.com/showthread.php?t=506427

Any help is greatly appreciated!

Thanks
adriank is offline   Reply With Quote
 


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 10:07.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.