4WD Request Service on EVO X SST? - Mitsubishi Lancer Register Forum
 
 

Go Back   Mitsubishi Lancer Register Forum > Technical > Technical Questions

Reply
 
Thread Tools Rate Thread Display Modes
Old 07-12-2011, 17:43   #1
cooin
Registered User
 
Join Date: Jan 2007
Posts: 17
4WD Request Service on EVO X SST?

got car few days, then 4wd warning light on, said request service, then send to main dealer, they said both rear tyres to low cause AYC go wrong, then replace both rear tyers, but after that warning light come back again......anyone can help? thanks.

btw, my car is evo x sst, warning light come on every time after drive 3-4 miles...thx
cooin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2011, 18:58   #2
KenX
Registered User
 
Join Date: Jan 2011
Location: In a Snap-On Van
Car: Iveco Daily
My Car
Posts: 5,092
Is it when you rag it? Could be over boosting if so.....
__________________
Why have 3 pedals when you've only got 2 feet............
KenX is offline   Reply With Quote
Old 07-12-2011, 19:14   #3
cooin
Registered User
 
Join Date: Jan 2007
Posts: 17
Quote:
Originally Posted by KenX View Post
Is it when you rag it? Could be over boosting if so.....
...totally stock car...could over boost? thx~~~
cooin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2011, 20:41   #4
MotoIntrest
Senior User
 
Join Date: Feb 2008
Location: london/kent
Car: Evo 4
Posts: 3,837
did they not tell you the fault code that came out?

where about in the country are you? i would advise booking it into a dealer that knows about evos or one of the traders on here that knows evo X's.
__________________
Indigo GT boys are true gents
MotoIntrest is offline   Reply With Quote
Old 07-12-2011, 20:42   #5
MotoIntrest
Senior User
 
Join Date: Feb 2008
Location: london/kent
Car: Evo 4
Posts: 3,837
Oh, and have you let them know the fault is not fixed?
__________________
Indigo GT boys are true gents
MotoIntrest is offline   Reply With Quote
Old 07-12-2011, 20:50   #6
KenX
Registered User
 
Join Date: Jan 2011
Location: In a Snap-On Van
Car: Iveco Daily
My Car
Posts: 5,092
Quote:
Originally Posted by cooin View Post


...totally stock car...could over boost? thx~~~
Mine was totally stock when I bought it and was over boosting so bad the gearbox went into limp mode and opened the clutches
couldn't fix it, I was about to give the car back for refund and noticed a boost hose was split..........
__________________
Why have 3 pedals when you've only got 2 feet............
KenX is offline   Reply With Quote
Old 07-12-2011, 20:52   #7
cooin
Registered User
 
Join Date: Jan 2007
Posts: 17
Quote:
Originally Posted by MotoIntrest View Post
Oh, and have you let them know the fault is not fixed?
thanks m8, im in essex, i ring them today, they said there is no faulty code on ecu, they will check the wirring on tomorrow, but they said may need replace the control unit on AYC? honstly , i really don't know what is the control unit...never heared before...is there any good dealer around colchester known about the EVO X....thanks for help~
cooin is offline   Reply With Quote
Old 08-12-2011, 19:44   #8
cooin
Registered User
 
Join Date: Jan 2007
Posts: 17
update, main dealer call me said the AYC fuel pump gone.......2267.87 include vat plus labour to fix......
cooin is offline   Reply With Quote
Old 08-12-2011, 20:01   #9
michty_me
Senior User
 
michty_me's Avatar
 
Join Date: Jan 2009
Car: Forged Evo X CT-500
My Car
Posts: 7,485
A few threads up over the past few months with regards to AYC pump failure on Evo X's.
Your best bet would be to remove the pump and get it to a specialist such as Harry Hockley, Rogerrally, FQ Performance (All on here I believe)
__________________
michty_me is offline   Reply With Quote
Old 08-12-2011, 20:18   #10
Sider
Senior User
 
Sider's Avatar
 
Join Date: Dec 2007
Location: Leeds
Posts: 20,123
As Mitchy me says, you may well be able to get it repaired a lot cheaper if the car is out of warranty
Sider is offline   Reply With Quote
Old 08-12-2011, 22:04   #11
cooin
Registered User
 
Join Date: Jan 2007
Posts: 17
thanks for the help~~~main dealer said may ask mitsubishi office to check, maybe could do it under the warranty, but actually my warranty is end of Oct...so fingercross~~~
cooin is offline   Reply With Quote
Old 09-12-2011, 03:01   #12
michty_me
Senior User
 
michty_me's Avatar
 
Join Date: Jan 2009
Car: Forged Evo X CT-500
My Car
Posts: 7,485
Here's hoping that they won't be a bunch of helmets and allow you to get it sorted under warranty as a good will gesture.
__________________
michty_me is offline   Reply With Quote
Old 09-12-2011, 09:54   #13
tflpunk
Registered User
 
Join Date: Mar 2010
Posts: 346
Quote:
Originally Posted by KenX View Post
Mine was totally stock when I bought it and was over boosting so bad the gearbox went into limp mode and opened the clutches
couldn't fix it, I was about to give the car back for refund and noticed a boost hose was split..........
That sounds familiar! (my thread above "5k"). I'll check the hose for splits after work.
tflpunk is offline   Reply With Quote
Old 09-12-2011, 10:00   #14
Paul Ventress
Registered User
 
Join Date: Jan 2006
Location: york
Car: evo x sst. 440bhp and 423lbft
My Car
Posts: 1,269
Quote:
Originally Posted by cooin View Post
update, main dealer call me said the AYC fuel pump gone.......2267.87 include vat plus labour to fix......
my nearest dealer quoted me £2,870 to supply and fit new ayc pump. then after several hours got a call from them that he could now do it for£1,350.
Paul Ventress is offline   Reply With Quote
Old 09-12-2011, 11:47   #15
Sider
Senior User
 
Sider's Avatar
 
Join Date: Dec 2007
Location: Leeds
Posts: 20,123
Quote:
Originally Posted by Paul Ventress View Post
my nearest dealer quoted me £2,870 to supply and fit new ayc pump. then after several hours got a call from them that he could now do it for£1,350.
Was that as a good will gesture/contribution from Paul?
Sider is offline   Reply With Quote
Mitsubishi Lancer Register
Sponsored Links
Advertisement
 
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT. The time now is 02:03.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.